1105 Spiral Matrix (25分)

题目

This time your job is to fill a sequence of N N N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m m m rows and n n n columns, where m m m and n n n satisfy the following: m × n m\times n m×n must be equal to N N N; m ≤ n m\le n mn; and m − n m-n mn is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N N N. Then the next line contains N N N positive integers to be filled into the spiral matrix. All the numbers are no more than 1 0 4 10^4 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

bool cmp(int a, int b){
    return a > b;
}

int main(){
    int N, m, n;
    vector<int> d;
    vector<vector<int> > mp;
    scanf("%d", &N);
    d.resize(N);
    for(int i=0; i<N; i++)
        scanf("%d", &d[i]);
    sort(d.begin(), d.begin()+N, cmp);
    for(int i=N; i>=sqrt(N); i--){
        if(N%i == 0){
            m = i;
            n = N/m;
        }
    }
    //printf("%d %d\n", m, n);
    mp.resize(m);
    for(int i=0; i<m; i++)
        mp[i].resize(n);
    int cnt = 0, level = 0;
    while(cnt < N){
        for(int i=level; i<n-level && cnt < N; i++){
            mp[level][i] = d[cnt++];
        }
        for(int i=level+1; i<m-level-1 && cnt < N; i++){
            mp[i][n-level-1] = d[cnt++];
        }
        for(int i=n-level-1; i>=level && cnt < N; i--){
            mp[m-level-1][i] = d[cnt++];
        }
        for(int i=m-level-2; i>= level+1 && cnt < N; i--){
            mp[i][level] = d[cnt++];
        }
        level++;
    }
    for(int i=0; i<m; i++){
        for(int j=0; j<n; j++){
            if(j)
                printf(" ");
            printf("%d", mp[i][j]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值