1117 Eddington Number (25分)

题目

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E E E – that is, the maximum integer E E E such that it is for E E E days that one rides more than E E E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N N N days, you are supposed to find the corresponding E ( ≤ N ) E(\le N) E(N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1 0 5 ) N(\le10^5) N(105), the days of continuous riding. Then N N N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N N N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题目大意

这道题半天没看懂题意😢😢😢,百度之后才明白,题意如下:
给出N天,要求出一个最大的E天,每天骑行的距离都大于E。

思路

这道题关键在于读懂题目吧,我觉得,题目本身很简单,对N天的骑行距离排序,然后正向遍历,当距离大于i时,说明有i天骑行距离下雨i。

代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;

int main(){
    vector<int> v;
    int n;
    scanf("%d", &n);
    v.resize(n);
    for(int i=0; i<n; i++)
        scanf("%d", &v[i]);
    sort(v.begin(), v.end());
    int i;
    for(i=0; i<n; i++){
        if(v[i] > n-i)
            break;
    }
    printf("%d\n", n-i);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值