1118 Birds in Forest (25分)——(图的连通区域)

题目

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N ( ≤ 1 0 4 ) N(\le10^4) N(104) which is the number of pictures. Then N N N lines follow, each describes a picture in the format:

K K K B 1 B_1 B1 B 2 B_2 B2 B ​ K B_​K BK

where K K K is the number of birds in this picture, and B i B_i Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 1 0 4 10^4 104.

After the pictures there is a positive number Q ( ≤ 1 0 4 ) Q(\le10^4) Q(104) which is the number of queries. Then Q Q Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

题目大意

有很多张图片,图片上面有树有鸟,规定每张图片上的鸟都属于同一棵树(鸟的编号连续),要求求出有多少棵树,有多少只鸟,并且有K次查询,判断两只鸟是否在同一棵树上。

思路

我的第一天想法是图的连通区域问题,每遍历一个连同区域时,对这个连通区域编号,即对这棵树编号,那么访问连同区域的没一只鸟时,标记这只鸟属于那棵树,后边遍历直接比较即可;按这种方法可以解题,但仔细一想,这与经典的求连通区域问题有点区别,似乎更像是并查集的问题,但是目前还不会并查集,后序会跟新并查集的做法;

代码

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

int n;
vector<vector<int> > node(20001);
bool visited[20001];
int bird[10001];
int cnt = 0, total = 0;

void dfs(int root){
    visited[root] = true;
    if(root > n){
        bird[root-n] = cnt;
        total++;
    }
    for(int i=0; i<node[root].size(); i++){
        if(!visited[node[root][i]])
            dfs(node[root][i]);
    }
}

int main(){
    scanf("%d", &n);
    for(int i=1, k; i<=n; i++){
        scanf("%d", &k);
        visited[i] = false;
        for(int j=0, t; j<k; j++){
            scanf("%d", &t);
            node[i].push_back(n+t);
            node[n+t].push_back(i);
            visited[n+t] = false;
        }
    }
    for(int i=1; i<=n; i++){
        if(!visited[i]){
            dfs(i);
            cnt++;
        }
    }
    printf("%d %d\n", cnt, total);
    int k;
    scanf("%d", &k);
    for(int i=0; i<k; i++){
        int a, b;
        scanf("%d %d", &a, &b);
        if(bird[a] == bird[b])
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值