A Dangerous Maze 期望概念题

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

1

1

2

-10 -3

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

传送门在此

题意:n个门,选择每个门的概率相等,若第x个门为正数门则在xi时间内走出去,若第x个门为负数门则在xi时间内会回到原点,问能走出去的期望值是多少。

题解:就是最基础的期望的概念题,不懂期望,通过这题认识一下期望,做完这题,觉得期望就是每种可能性乘以在这种可能性下产生的值,然后把所有这种值都加起来。所以这题就是

若选择了正数门x,这个期望值的一部分就是1/n*x

若选择了负数门x,这个期望值的一部分就是1/n*(x+E)

所有很容易想出来的就是上面说的说有相加起来就行了

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int main(){
    int t, n;
    scanf("%d",&t);
    for(int o=1; o<=t; o++){
        scanf("%d",&n);
        int sum1=0, sum2=0, num=0;
        for(int i=1; i<=n; i++){
            int a;
            scanf("%d",&a);
            if(a>0) sum1+=a;
            else sum2+=-a, num++;
        }
        int ans1=sum1+sum2, ans2=n-num;
        if(!ans2) printf("Case %d: inf\n",o);
        else printf("Case %d: %d/%d\n",o,ans1/__gcd(ans1, ans2), ans2/__gcd(ans1, ans2));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值