Discovering Gold
You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.
Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.
Output
For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.
Sample Input
3
1
101
2
10 3
3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15
题意:给n个洞,每个洞中放有一定数量的黄金,起点是第一个洞,每次移动通过扔6面的筛子确定跳跃几格,跳到哪个洞了就会将这个洞中所有的黄金拿走。问调到最后一格的得到黄金数的期望是多少。
题解:最基础的期望题。一开b始的想法是dp[i]表示的是从第一个洞跳到第i个洞的期望值。无法解决,一直wa,不太知道原因,没办法只能换一种想法,dp[i]表示从第i个洞开始跳到最后的期望值。倒着写一遍就过了。
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[300];
int main(){
int t;
scanf("%d",&t);
for(int o=1; o<=t; o++){
int n;
scanf("%d",&n);
for(int i=1; i<=n; i++)
scanf("%lf",&dp[i]);
int k;
for(int i=n; i>=1; i--){
if(i>=n-6+1) k=n-i;
else k=6;
for(int j=i+1; j<=i+k; j++){
dp[i] += 1.0/k*dp[j];
}
}
printf("Case %d: %f\n",o,dp[1]);
}
return 0;
}