就单纯贴个代码。。。。。
嗷还有题目
Least Common Multiple
Find the least common multiple (LCM) of given n integers.
Input
n
a1 a2 … an
n is given in the first line. Then, n integers are given in the second line.
Output
Print the least common multiple of the given integers in a line.
Constraints
2 ≤ n ≤ 10
1 ≤ ai ≤ 1000
Product of given integers ai(i=1,2,…n) does not exceed 231-1
Sample Input 1
3
3 4 6
Sample Output 1
12
Sample Input 2
4
1 2 3 5
Sample Output 2
30
主要就是这个公式:a*b = lcm(a,b)*gcd(a,b);
还有辗转相除法写法。简单题。
#include <cstdio>
int gcd(int a, int b)
{
return b ? gcd(b, a%b): a;
}
int m[50];
int main()
{
int n;
scanf("%d",&n);
int mui = 1;
for(int i = 1; i <= n; i ++) scanf("%d",&m[i]);
int g = gcd(m[1], m[2]);
int ans = m[1]/g*m[2];
for(int i = 3; i <= n; i ++) ans = ans/gcd(ans, m[i])*m[i];
printf("%d\n",ans);
return 0;
}