题目地址

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

#include <iostream>
#include <vector>
#include<algorithm>
#include <cmath>
#include<map>
#include<cstring>
#include<queue>
#include<string>
#include<set>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn=100010,inf=100000000;
int a[maxn],b[maxn];
int n;
void adjust(int fa,int high){
    int child=fa*2;
    while(child<=high){          //下滤,不断和自己的大孩子互换;
        if(a[fa*2+1]>a[fa*2]&&fa*2+1<=high) child++;            //一定一定要注意下标和value;
        if(a[child]>a[fa]){
            swap(a[fa],a[child]);
            fa=child;
            child=fa*2;
        }
        else break;             //记住break;
    }
}
bool same(int a[],int b[]){
    for(int i=1;i<=n;i++){
        if(a[i]!=b[i]) return 0;
    }
    return 1;
}
int main(){
    cin>>n;
    for(int i=1;i<=n;i++) cin>>a[i];for(int i=1;i<=n;i++) cin>>b[i];
    int i;
    for( i=2;b[i]>=b[i-1]&&i<=n;i++);int j=i;           //一定要大于等于;
    for(;a[i]==b[i]&&i<=n;i++);
    if(i==n+1){
        cout<<"Insertion Sort"<<endl;
        sort(a+1,a+j+1);
        for(int i=1;i<=n;i++){
            if(i!=1) cout<<" ";
            cout<<a[i];
        }
    }
    else{
        cout<<"Heap Sort"<<endl;bool flag=0;
        for(int i=n/2;i>=1;i--) adjust(i,n);         //通过下标层序;从最后一个有子结点到根节点调整位置;
        for(int i=n;i>=1;i--){
            if(same(a,b)) flag=1;
            swap(a[i],a[1]);
            adjust(1,i-1);         //从最后子(pos)开始不断和跟互换,调整pos-1成大顶堆;
            if(flag){
    

        for(int i=1;i<=n;i++){
                if(i!=1) cout<<" ";
                cout<<a[i];
            }
            break;
          }
    }
    
}

}