1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

一开始想到的是大数加法,但是有负数,所以相加很麻烦,参考了网上的答案,利用了long long最大能表示2^63这一特点。

两个[0,2^63)内的数相加,若结果小于零,则是结果太大,溢出,所以一定是大于可以表示的C。

两个(-2^63,0]内的数相加,若结果大约等于零,则是结果太小,溢出,所以一定是小于可以表示的C。

其他情况是没有发生溢出的情况下,按照普通比较方法。

#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;


int main()
{
	int t;
	cin >> t;
	int num = 1;
	for (int i = 0; i < t; i++)
	{
		long long a, b, c;
		cin >> a >> b >> c;
		long long res = a + b;
		if (a > 0 && b > 0 && res < 0)
			cout << "Case #" << num << ": true" << endl;
		else if (a < 0 && b < 0 && res>=0)
			cout << "Case #" << num << ": false" << endl;
		else if (res > c)
			cout << "Case #" << num << ": true" << endl;
		else
			cout << "Case #" << num << ": false" << endl;
		num++;
	}
	
	 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值