1020 Tree Traversals (25 分)

大佬真是强啊~~~ 

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2
#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<math.h>
using namespace std;

struct node
{
	int index;
	int value;
};
vector <node>no;
vector<int>a, b;
bool cmp(node n1,node n2)
{
	return n1.index < n2.index;
}
void pre(int root, int start, int end, int index)
{
	int i = 0;
	if (start > end)
		return;
	while (b[i] != a[root])i++;
	no.push_back ({ index,a[root] });
	pre(root - end - 1 + i, start, i - 1, 2 * index + 1);
	pre(root - 1, i + 1, end, 2 * index + 2);
}
int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		int m;
		cin >> m;
		a.push_back(m);
	}
	for (int i = 0; i < n; i++)
	{
		int m;
		cin >> m;
		b.push_back(m);
	}
	pre(n - 1, 0, n - 1, 0);
	sort(no.begin(), no.end(), cmp);
	for (int i = 0; i < no.size(); i++)
	{
		cout << no[i].value;
		if (i != no.size() - 1)
			cout << " ";
	}
}

中序和后序遍历结合,输出层次遍历。

首先利用递归函数,构造出这个二叉树的形态,后序的最后一个元素一定是当前的根节点root,扫描中序遍历序列找到与根节点数值相等的结点,记录位置为i,则i左边为左子树,i右边为右子树,左子树根节点在后序遍历序列中下标为root-(end-i)-1;end-i为右子树结点个数,递归调用函数pre,传入左子树和右子树,更新index值,用来标记结点下标,构造vector序列。

对vector序列按index递增排序,输出vector序列即为层次遍历顺序。

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值