1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HHis in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

先把来的人按时间先后排成一队,然后给窗口赋初始值,找出三个窗口中最早结束的,然后 将最早来的人安排在最早结束的窗口,如果人来的时间大于窗口借书的时间,则人来之后可以直接服务,更新窗口结束的时间,否则,人需等待窗口结束,等待时间为窗口结束时间减去人来的时间,更新窗口结束时间。

#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<math.h>
using namespace std;

struct cus
{
	int come;
	int time;
};
bool cmmp(cus c1, cus c2)
{
	return c1.come < c2.come;
}
int main()
{
	int n, k;
	cin >> n >> k;
	vector<cus>c;
	for (int i = 0; i < n; i++)
	{
		int h, m, s, w;
		char mao;
		cin >> h >> mao >> m >> mao >> s >> w;
		cus cc;
		int tempss = h * 60 * 60 + m * 60 + s;
		if (tempss < 61200)
		{
			cc.come = tempss;
			cc.time = w * 60;
			c.push_back(cc);
		}
	}
	sort(c.begin(), c.end(), cmmp);
	vector<int>win(k, 28800);
	double res = 0;
	for (int i = 0; i < c.size(); i++)
	{
		int temptime=0, mintime = win[0];
		for (int j = 1; j < win.size(); j++)
		{
			if (mintime > win[j])
			{
				temptime = j;
				mintime = win[j];
			}
		}
		if (c[i].come > win[temptime])
			win[temptime] = c[i].come + c[i].time;
		else
		{
			res += win[temptime] - c[i].come;
			win[temptime] += c[i].time;
		}
	}
	if (res == 0)
		cout << "0.0" << endl;
	else
		cout << fixed << setprecision(1) << res / (c.size()*60) << endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值