1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

getchar()清空缓冲。 

#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;

int main()
{
	int n;
	cin >> n;
	string *a = new string[n];
	int min = 257;
	char c[257];
	int cnt = 0,flag,ff=0;
	getchar();
	for (int i = 0; i < n; i++)
	{
		getline(cin, a[i]);
		reverse(a[i].begin(), a[i].end());
		if (min > a[i].length())
			min = a[i].length();
	}
	for (int j = 0; j < min; j++)
	{
		char m = a[0][j];
		flag = 0;
		for (int i = 1; i < n; i++)
			if (m != a[i][j])
				flag = 1;
		if (flag == 0)
		{
			c[cnt++] = m;
			ff = 1;
		}
		else
			break;
	}
	//cout << strlen(c) << endl;
	if (ff)
		for (int i = cnt - 1; i >= 0; i--)
			cout << c[i];
	else
		cout << "nai" << endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值