1081 Rational Sum (20 分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24
#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;

long int gys(long int a,long int b)
{
	a = abs(a);
	b = abs(b);
	long int c = b;
	while (a%b != 0)
	{
		c = a % b;
		a = b;
		b = c;
	}
	return c;
}
long int gbs(long int a,long int b, long int g)
{
	return a * b / g;
}
int main()
{
	int n;
	cin >> n;
	long int *a = new long int[n];
	long int *b = new long int[n];
	char c;
	long int sum = 0,m=0;
	//cout << gys(-1, 6);
	for (int i = 0; i < n; i++)
	{
		cin >> a[i] >> c >> b[i];
	}
	for (int i = 0; i <n-1; i++)
	{
		long int gy=gys(b[i], b[i + 1]);
		long int gb=gbs(b[i], b[i + 1], gy);
		sum = gb / b[i] * a[i]+gb/b[i+1]*a[i+1];
		long int tt=sum / gb;
		m += tt;
		//cout <<sum << " " << gb << endl;
		sum -= tt * gb;
		b[i + 1] = gb/ gys(sum, gb);
		a[i + 1] = sum/ gys(sum, gb);
	}
	if (m != 0)
		cout << m;
	if (m != 0 && a[n - 1] != 0)
		cout << " ";
	if(a[n - 1]!=0)
	cout <<a[n - 1] << c << b[n - 1]<< endl;
	if (m == 0 && a[n - 1] == 0)
		cout << 0 << endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值