1016 Phone Bills (25 分)

一、题目 

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-linerecord. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

二、题目大意 

 已知用户的通话记录,给了24小时每小时时间段的收费标准,计算用户在某一月份内通话总费用。

用户输出格式按姓名字母递增的顺序。

三、解题思路

1、找到用户的通话记录对(on-line off-line)-->对用户姓名、同一用户通话时间进行排序:首先对用户的姓名进行排序。一个用户对应很多条通话记录,将同一个用户的信息按时间顺序进行排序后,扫描记录,相邻的(on-line off-line)一定是一组通话记录,这里的时间为方便起见转换成分钟,计算方式是以1号0点0分为起始点,计算分钟差值。

2、找到相邻的一组通话记录后,存在map中,方便计算价格

3、计算价格:以1号0点0分为起始点,通话时间与相应的rate相乘,用off-line的通话费用减去on-line的通话费用。

四、数据结构

1、结构体user:用来存储姓名,月份,天,小时,分钟,总分钟,状态

2、vector数组:类型user   vector<user>(n)  //vector数组申请动态空间

3、map<string,vector<user>> //按用户姓名存储一个用户的通话信息:包含多个on-line,off-line

五、代码

#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<math.h>
using namespace std;

struct user
{
	string name;
	int mon;
	int d;
	int h;
	int m;
	int smin;
	int status;
};

bool cmp(user u1, user u2)
{
	return u1.name != u2.name ? u1.name < u2.name : u1.smin < u2.smin;
}
double getcharge(user u1,int *rate)
{
	double bills=0;
	int d = u1.d;
	for (int i = 0; i < 24; i++)
		bills += rate[i]*60;
	bills *= d;
	int h = u1.h;
	for (int i = 0; i < h; i++)
		bills += rate[i] * 60;
	bills += u1.m*rate[h];
	return bills/100;
}

int main()
{
	int rate[24];
	map<string, vector<user>>mmp;
	for (int i=0; i < 24; i++)
		cin >> rate[i];
	int n;
	cin >> n;
	vector<user>u(n);//申请vector数组
	char mao;
	for (int i = 0; i < n; i++)
	{
		cin >> u[i].name >> u[i].mon >> mao >> u[i].d >> mao >> u[i].h >> mao >> u[i].m;
		string temp;
		cin >> temp;
		u[i].status = temp == "on-line" ? 1 : 0;
		u[i].smin = u[i].d * 24 * 60 + u[i].h * 60 + u[i].m;
	}
	sort(u.begin(),u.end(),cmp);
	for (int i = 1; i < n; i++)
		if (u[i].name == u[i - 1].name&&u[i].status == 0 && u[i - 1].status == 1)
		{
			mmp[u[i - 1].name].push_back(u[i - 1]);//1
			mmp[u[i].name].push_back(u[i]);//0
		}
	for (auto it : mmp)
	{
		vector<user>temp = it.second;
		double bills = 0, sum = 0;
		cout << it.first << " "<< setfill('0') << setw(2) <<temp[0].mon<<endl;
		for (int i = 0; i < temp.size(); i += 2)
		{
			cout << setfill('0') << setw(2) << temp[i].d << mao << setfill('0') << setw(2) << temp[i].h << mao << setfill('0') << setw(2) << temp[i].m << " ";
			cout << setfill('0') << setw(2) << temp[i + 1].d << mao << setfill('0') << setw(2) << temp[i + 1].h << mao << setfill('0') << setw(2) << temp[i + 1].m << " ";
			bills=getcharge(temp[i+1], rate) - getcharge(temp[i], rate);
			sum += bills;
			cout << temp[i+1].smin - temp[i].smin << " " << "$" <<fixed<<setprecision(2)<< bills << endl;
		}
		cout << "Total amount: " << "$" << sum << endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值