6580: Splitting Pile(中石油)

6580: Splitting Pile

时间限制: 1 Sec  内存限制: 128 MB
提交: 293  解决: 88
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Snuke and Raccoon have a heap of N cards. The i-th card from the top has the integer ai written on it.
They will share these cards. First, Snuke will take some number of cards from the top of the heap, then Raccoon will take all the remaining cards. Here, both Snuke and Raccoon have to take at least one card.
Let the sum of the integers on Snuke's cards and Raccoon's cards be x and y, respectively. They would like to minimize |x−y|. Find the minimum possible value of |x−y|.
Constraints
2≤N≤2×105
−109≤ai≤109
ai is an integer.

输入

Input is given from Standard Input in the following format:
N
a1 a2 … aN

输出

Print the answer.

样例输入

6
1 2 3 4 5 6

样例输出

1

提示

If Snuke takes four cards from the top, and Raccoon takes the remaining two cards, x=10, y=11, and thus |x−y|=1. This is the minimum possible value.

来源/分类

ABC067&ARC078 

题意:一串数字,Snuke从起点数字选择连续的一段,Raccoon选择剩下的一段,求这两段数字的和的最小的差值(绝对值)

用前缀和求解(避免超时)

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll inf=(2e5)*(1e9)+5;
const int MAXN=2e5+5;
ll a[MAXN];
ll sum[MAXN];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        ll cnt=0;
        for(int i=1;i<=n;i++)
        {
           scanf("%lld",&a[i]);
            sum[i]=sum[i-1]+a[i];
            cnt+=a[i];
        }
        ll minn=inf;
        for(int i=1;i<n;i++)
        {
            if(minn>abs(2*sum[i]-cnt))
                minn=abs(2*sum[i]-cnt);
        }
        printf("%lld\n",minn);
    }

    return 0;
}
 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值