7224: The puzzle

五更眠;最无益,莫过一日曝十日寒。

7224: The puzzle

时间限制: 1 Sec  内存限制: 128 MB
提交: 90  解决: 46
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Kayaking is playing a puzzle game containing n different blocks. He marks the blocks with integers from 1 to n, which show the blocks’ original positions. Each time he can exchange two blocks and he wants to know how many times he needs at least to restore the puzzle.

 

输入

The input starts with one line contains exactly one positive integer T which is the number of test cases.
Each test case contains two lines.
The first line contains an integer, which indicates the number of puzzle pieces.
The second line contains n different integers, the i-th number means the mark of the block in the i-th position.

 

输出

For each test case, output one line with one number represents the minimum operations.

 

样例输入

2
4
2 3 4 1
4
2 1 4 3

 

样例输出

3
2

 

提示

1≤T≤20,1≤n≤100000

 

来源/分类

2018黑龙江省赛 

 

 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int a[100010],vis[100010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        int n,ans=0;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(int i=1; i<=n; i++)
        {
            int j=a[i],num=0;
            while(!vis[j])
            {
                vis[j]=1;
                j=a[j];
                num++;
            }
            if(num>0)
                ans+=num-1;
        }


        printf("%d\n",ans);
    }
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值