The puzzle

The puzzle

Kayaking is playing a puzzle game containing n different blocks. He marks the blocks with integers from 1 to n, which show the blocks’ original positions. Each time he can exchange two blocks and he wants to know how many times he needs at least to restore the puzzle.
Input
The input starts with one line contains exactly one positive integer which is the number of test cases.
Each test case contains two lines.
The first line contains an integer, which indicates the number of puzzle pieces.
The second line contains n different integers, the i-th number means the mark of the block in the i-th position.
Output
For each test case, output one line with one number represents the minimum operations.
Sample Input
2
4
2 3 4 1
4
2 1 4 3
Sample Output
3
2
Hint
1<=T<=20,1<=n<=100000

输入的时候 要把这个数的当前位置是什么和当前位置是什么数 然后在交换数的时候另一个记录位置的数组也要变,直接代码

#include<iostream>
#include<algorithm>
#include<cmath>
#include<string.h>
using namespace std;
long long int n,m,k,flag=0,a[1000009],b[1000009];
int main(){
    cin>>n;
    while(n--)
    {
        int cnt=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&k);
            a[i]=k;
            b[k]=i;
        }
        for(int i=1;i<=m;i++)
        {
            if(a[i]!=i)
            {
                cnt++;
                k=b[i];
                b[a[i]]=b[i];
                b[i]=i;
                swap(a[i],a[k]);
            }
        }
        cout<<cnt<<endl;
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值