guruguru(差分数组)

                                            guruguru

                                                               时间限制: 1 Sec  内存限制: 128 MB
                                                                              提交: 44  解决: 19
                                                               [提交] [状态] [讨论版] [命题人:admin]

题目描述

Snuke is buying a lamp. The light of the lamp can be adjusted to m levels of brightness, represented by integers from 1 through m, by the two buttons on the remote control.
The first button is a "forward" button. When this button is pressed, the brightness level is increased by 1, except when the brightness level is m, in which case the brightness level becomes 1.
The second button is a "favorite" button. When this button is pressed, the brightness level becomes the favorite brightness level x, which is set when the lamp is purchased.
Snuke is thinking of setting the favorite brightness level x so that he can efficiently adjust the brightness. He is planning to change the brightness n−1 times. In the i-th change, the brightness level is changed from ai to ai+1. The initial brightness level is a1. Find the number of times Snuke needs to press the buttons when x is set to minimize this number.

Constraints
2≤n,m≤105
1≤ai≤m
ai≠ai+1
n, m and ai are integers.

输入

Input is given from Standard Input in the following format:
n m
a1 a2 … an

输出

Print the minimum number of times Snuke needs to press the buttons.

样例输入

4 6
1 5 1 4

样例输出

5

                                                                                    [提交]         [状态]

题意

两个按钮, 一个可以使计数器+1(计数器数字从1-m), 当前值为m时, 再+1就变成了1。另一个按钮储存了一个值x, 按一下就从任意值会变成x。n-1次操作, 由一个数组a[n]描述, 第i次操作: 将计数器从a[i]调到a[i+1]。将x设置为某个值, 使得所有操作需要按按钮的次数总和最小, 输出这个最小值 。

思考: 对于L=a[i] 和 R=a[i+1] 

设置一个数组sum, sum[i] := 如果x在i位置, 对于所有操作, 使用第二个按钮能够减少的操作次数(相对于只使用第一个按钮)

(从a[i]到a[i+1]档,可以按a[i+1]-a[i]次,假如x设置在其中间位置,只需按a[i+1]-x+1次即可,那么可以将每个a[i]和a[i+1]看成一条线段,只要x设置在线段上,这次操作就有相应的次数减少,减少的次数为x-a[i]-1次,x在线段外即对当前操作无影响)

考虑   ①:R==L 不需要按 没啥用  ② : R-L==1 无论X是什么也没有用 ③ R-L>1 那么对于存在一个X在L-R区间

假如X=L+2可以减少按键一次

x在l+2位置使用第二个按钮能够减少1次操作, 在l+3位置能减少2次… 在r位置能够减少r-(l+2)+1次操作

所以sum[l+2] += 1, sum[l+3] += 2 ... sum[r] += r-(l+2)+1,对于L>R的情况考虑R=R+m.这样就不需要考虑越界问题

因此维护X从1到m的值即可。ans记录如果都是按一下需要的最大总数。Ans记录最大的如果X在某位置的需要减少的次数

Ans=max(Ans,sum[i]+sum[i+m])(1<=i<=m)  因为有R=R+m 所以是i+m。这样的话暴力复杂度为n*m

所以利用前缀和优化成O(1)

如果要将sum[l]到sum[r]依次加上1, 2, … r-l+1
我们可以这样: sum[i] += 1, sum[r+1] -= r-l+1 + 1, sum[r+2] += r-l+1, 每次只更新这三个值, 最后再从头到尾sum[i] += p[i-1]
具体的一组例子, 比如l=2, r=5

差分数组(区间内每次加一,恰好为前缀和)

理解的话可以从下面往上面理解然后写代码的话从上往下写

更新操作复杂度1234567
更新三个值O(1)01000-54
p[i]+=p[i-1]O(n)01111-40
p[i]+=p[i-1]O(n)0123400

所以最后总复杂度O(n+m)

来自大佬的思路,打死我也想不到


#include<bits/stdc++.h>

using namespace std;

long long a[200005];

long long sum[200005];

int main()

{

	int n,m;

	scanf("%d%d",&n,&m);

	for(int i=0;i<n;i++)

		scanf("%lld",&a[i]);

		

	long long ans=0;

	for(int i=1;i<n;i++)

	{

		long long l=a[i-1];

		long long r=a[i];

		if(l>r)

			r=r+m;

		ans = ans + r- l;

		if(r-l>1)

		{

			sum[l+2] = sum[l+2] +1;

			sum[r+1] = sum[r+1] - (r-l) ;

			sum[r+2] = sum[r+2] +(r-l-1);

		}	

	}

	for(int i=1;i<=2*m;i++)

		sum[i] = sum[i] + sum[i-1];

	for(int i=1;i<=2*m;i++)

		sum[i]= sum[i] + sum[i-1];	

	long long Ans=0;

	for(int i=1;i<=m;i++)

		Ans= max(Ans, sum[i] + sum[i+m]); 

	printf("%lld\n",ans-Ans);

	return 0;

} 

 

 

 

 

 

在使用Python来安装geopandas包时,由于geopandas依赖于几个其他的Python库(如GDAL, Fiona, Pyproj, Shapely等),因此安装过程可能需要一些额外的步骤。以下是一个基本的安装指南,适用于大多数用户: 使用pip安装 确保Python和pip已安装: 首先,确保你的计算机上已安装了Python和pip。pip是Python的包管理工具,用于安装和管理Python包。 安装依赖库: 由于geopandas依赖于GDAL, Fiona, Pyproj, Shapely等库,你可能需要先安装这些库。通常,你可以通过pip直接安装这些库,但有时候可能需要从其他源下载预编译的二进制包(wheel文件),特别是GDAL和Fiona,因为它们可能包含一些系统级的依赖。 bash pip install GDAL Fiona Pyproj Shapely 注意:在某些系统上,直接使用pip安装GDAL和Fiona可能会遇到问题,因为它们需要编译一些C/C++代码。如果遇到问题,你可以考虑使用conda(一个Python包、依赖和环境管理器)来安装这些库,或者从Unofficial Windows Binaries for Python Extension Packages这样的网站下载预编译的wheel文件。 安装geopandas: 在安装了所有依赖库之后,你可以使用pip来安装geopandas。 bash pip install geopandas 使用conda安装 如果你正在使用conda作为你的Python包管理器,那么安装geopandas和它的依赖可能会更简单一些。 创建一个新的conda环境(可选,但推荐): bash conda create -n geoenv python=3.x anaconda conda activate geoenv 其中3.x是你希望使用的Python版本。 安装geopandas: 使用conda-forge频道来安装geopandas,因为它提供了许多地理空间相关的包。 bash conda install -c conda-forge geopandas 这条命令会自动安装geopandas及其所有依赖。 注意事项 如果你在安装过程中遇到任何问题,比如编译错误或依赖问题,请检查你的Python版本和pip/conda的版本是否是最新的,或者尝试在不同的环境中安装。 某些库(如GDAL)可能需要额外的系统级依赖,如地理空间库(如PROJ和GEOS)。这些依赖可能需要单独安装,具体取决于你的操作系统。 如果你在Windows上遇到问题,并且pip安装失败,尝试从Unofficial Windows Binaries for Python Extension Packages网站下载相应的wheel文件,并使用pip进行安装。 脚本示例 虽然你的问题主要是关于如何安装geopandas,但如果你想要一个Python脚本来重命名文件夹下的文件,在原始名字前面加上字符串"geopandas",以下是一个简单的示例: python import os # 指定文件夹路径 folder_path = 'path/to/your/folder' # 遍历文件夹中的文件 for filename in os.listdir(folder_path): # 构造原始文件路径 old_file_path = os.path.join(folder_path, filename) # 构造新文件名 new_filename = 'geopandas_' + filename # 构造新文件路径 new_file_path = os.path.join(folder_path, new_filename) # 重命名文件 os.rename(old_file_path, new_file_path) print(f'Renamed "{filename}" to "{new_filename}"') 请确保将'path/to/your/folder'替换为你想要重命名文件的实际文件夹路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值