【数位dp】 HDU - 3555 D - Bomb

D - Bomb HDU - 3555 

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.
 

求出现连续的49有多少个

因为数据范围很大,longlong

所以记得开大数组啊!!!

#include <bits/stdc++.h>
#define ll long long
using namespace std;
ll dp[25][2];
ll a[25],t[25];
ll n;

ll dfs(int pos, int state, bool limit)  //第几位,是否前一位为4,是否是上界
{
    if(pos == 0) return 0;//因为求的是连续的49,所以单个字符肯定是错的,返回0
    if(!limit && dp[pos][state]>=0) return dp[pos][state]; //出现过了有没有界限,直接返回
    int up = limit ? a[pos] : 9;
    ll ans = 0;
    for(int i = 0 ; i<=up ; i++)
    {
        if(state && i == 9) ans+=limit ? n % t[pos-1] + 1 : t[pos-1]; //出现49,就代表后面的一切数都可以,+1,不能忘了还有个0
        else ans+=dfs(pos - 1, i == 4, limit && i == a[pos]);  //否则,就正常递归
    }
    if(!limit) dp[pos][state] = ans;
    return ans;
}

ll solve(ll x)
{
    int pos = 0;
    while(x)
    {
        a[++pos] = x%10;
        x/=10;
    }
    return dfs(pos, 0, 1);
}

int main()
{
    memset(dp, -1, sizeof(dp));
    t[0] = 1;
    for(int i = 1 ; i <=20 ; i++) t[i] = t[i-1]*10;  //预处理,t[2]=100,那么4956,,递归时到了上界,就是n%t[2]+1,有57个,没有上界,直接加t[2]
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%lld", &n);
        printf("%lld\n", solve(n));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值