Bomb HDU - 3555 (数位dp)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15


        
  
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
using namespace std;
int a[25];
long long dp[25][2][12];//当前位数,是否已包含49,前一位是几
    //      当前位置     是否包含49。  前一位      限制位
long long dfs(int pos, bool have, int pre,  bool limit) {
        //如果已枚举完,并且已经包含49 则输出1,否则0了。
    if (pos == -1) return have;
        //记忆化dp的正确姿势
    if (!limit && dp[pos][have][pre] != -1) return dp[pos][have][pre];
    int up = limit ? a[pos] : 9;
    long long temp = 0;
    
    for (int i = 0; i <= up; ++i) {
        if (pre == 4 && i == 9) {//存在49的状态
            temp += dfs(pos-1, true, i, limit && i == a[pos]);
        } else {                 //不存在49的状态
            temp += dfs(pos-1, have, i, limit && i == a[pos]);
        }
    }
    
    if (!limit)
        dp[pos][have][pre] = temp;
    return temp;
}
long long solve(long long x) {
    int i = 0;
    while (x) {
        a[i++] = x%10;
        x /= 10;
    }
    return dfs(i-1, false, 0, 1);
}
int main() {
    int T;
    long long shit;
    cin >> T;
    while (T--) {
        memset(dp, -1, sizeof(dp));
        cin >>shit;
        cout << solve(shit) << endl;
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值