【Tarjan求汇点】POJ - 2553 F - The Bottom of a Graph

F - The Bottom of a Graph POJ - 2553

e will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E)is called a directed graph. 
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then pis called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1)
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from vv is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graphG. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the setV={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

问你瓶子最底端的是哪些点,按序输出

瓶子是u->v->w这样的话,w就是底端,所以就是问你缩点后出度为0的点(在此点中的所有点)是哪些

出度为0的点就叫做汇点

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 10010

int n,m;
vector<int> g[maxn];

int Bcnt; // 强连通分量的个数;
int Top; // 栈顶;
int Index; // 时间戳;
int low[maxn], dfn[maxn];
int belong[maxn], Stack[maxn];
bool instack[maxn];
int out[maxn],ans[maxn];

void Init_tarjan()
{
    memset(ans,0,sizeof(ans));
    Bcnt= Top= Index= 0;
    for(int i=1; i<=n; i++)
    {
        low[i]= dfn[i]= 0;
    }
}
void Tarjan(int u)
{
    Stack[Top++]= u;
    instack[u]= 1;
    low[u]= dfn[u]= ++Index;
    for(int i=0; i<g[u].size(); i++)
    {
        int v= g[u][i];
        if( !dfn[v] )
        {
            Tarjan(v);
            low[u]= min( low[v], low[u] );
        }
        else if( instack[v] )
            low[u]= min( low[u], dfn[v] );
    }
    if( low[u]==dfn[u] )
    {
        ++Bcnt;
        int v;
        do{
            v= Stack[--Top];
            instack[v]= 0;
            belong[v]= Bcnt;
        }while( u!=v );
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        scanf("%d",&m);
        Init_tarjan();
        memset(out,0,sizeof(out));
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            g[x].push_back(y);
        }
        for(int i=1;i<=n;i++)
        {
            if(!dfn[i]) Tarjan(i);
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<g[i].size();j++)
            {
                int v=g[i][j];
                if(belong[v]==belong[i]) continue;
                else
                {
                    out[belong[i]]++;
                }
            }
        }
        int sum_out=0;
        for(int i=1;i<=Bcnt;i++)
        {
            if(!out[i])
            {
                for(int j=1;j<=n;j++)
                {
                    if(belong[j]==i)
                    {
                        sum_out++;
                        ans[sum_out]=j;
                    }
                }
            }
        }
        sort(ans+1,ans+1+sum_out);
        for(int i=1; i<=n; i++)
        {
            g[i].clear();
        }
        if(sum_out==0) printf("\n");
        else
        {
            for(int i=1;i<=sum_out;i++) printf("%d ",ans[i]);
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值