【费马小定理+快速幂取模】ACM-ICPC 2018 焦作赛区网络预赛 G. Give Candies

 G. Give Candies

There are N children in kindergarten. Miss Li bought them N candies. To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1...N) and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.

Input

The first line contains an integer T, the number of test case.

The next T lines, each contains an integer N.

1≤T≤100

1≤N≤10^100000

Output

For each test case output the number of possible results (mod 1000000007).

样例输入

1
4

样例输出

8

有n个孩子,n个糖果,从第一个孩子开始给,任意给随便数量的糖果,至少给一个

问你一共有多少种不同的给的方案,答案应该为2^(n-1)%1e9+7

n可以到10的100000次方,所以应当用降幂公式

费马小定理 (a^n)%mod,如果mod为质数,a^(n%(mod-1))%mod

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const ll mod=1e9+7;
ll quickpow(ll a,ll b)
{
    ll r=1;
    while(b)
    {
        if(b&1) r=r*a%mod;
        a=a*a%mod;
        b/=2;
    }
    return r;
}
char s[100005];

int main()
{
    int T;
    scanf("%d",&T);

    while(T--)
    {
        scanf("%s",s);
        int len=strlen(s);
        ll temp=0;
        for(int i=0;i<len;i++)
        {
            temp=(temp*10+s[i]-'0')%(mod-1);
        }
        temp--;
        if(temp<0) temp=mod-1;
        printf("%lld\n",quickpow(1LL*2,temp));
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值