【最大生成树】2017ACM/ICPC广西邀请赛  F - Destroy Walls  HDU - 6187

2017ACM/ICPC广西邀请赛 

F - Destroy Walls

 HDU - 6187 

Long times ago, there are beautiful historic walls in the city. These walls divide the city into many parts of area. 

Since it was not convenient, the new king wants to destroy some of these walls, so he can arrive anywhere from his castle. We assume that his castle locates at (0.6∗2–√,0.6∗3–√)(0.6∗2,0.6∗3). 

There are nn towers in the city, which numbered from 1 to n. The ith's location is (xi,yi)(xi,yi). Also, there are m walls connecting the towers. Specifically, the ith wall connects the tower uiui and the tower vivi(including the endpoint). The cost of destroying the ith wall is wiwi. 

Now the king asks you to help him to divide the city. Firstly, the king wants to destroy as less walls as possible, and in addition, he wants to make the cost least.

The walls only intersect at the endpoint. It is guaranteed that no walls connects the same tower and no 2 walls connects the same pair of towers. Thait is to say, the given graph formed by the walls and towers doesn't contain any multiple edges or self-loops. 

Initially, you should tell the king how many walls he should destroy at least to achieve his goal, and the minimal cost under this condition. 

Input

There are several test cases. 

For each test case: 

The first line contains 2 integer n, m. 

Then next n lines describe the coordinates of the points. 

Each line contains 2 integers xi,yixi,yi. 

Then m lines follow, the ith line contains 3 integers ui,vi,wiui,vi,wi 

|xi|,|yi|≤105|xi|,|yi|≤105 

3≤n≤100000,1≤m≤2000003≤n≤100000,1≤m≤200000 

1≤ui,vi≤n,ui≠vi,0≤wi≤100001≤ui,vi≤n,ui≠vi,0≤wi≤10000 

Output

For each test case outout one line with 2 integers sperate by a space, indicate how many walls the king should destroy at least to achieve his goal, and the minimal cost under this condition. 

Sample Input

4 4
-1 -1
-1 1
1 1
1 -1
1 2 1
2 3 2
3 4 1
4 1 2

Sample Output

1 1

题意:国王的领土被分割成n个地方,国王想到达他领土的每一个地方,但是现在有一些城墙隔绝两个地方,拆掉城墙需要耗费一些财力物力,国王想拆最小的城墙数,花费最小的人力物力。先给出的n个坐标值,然后给出这个城墙连接的两个地方和拆掉需要耗费的代价了。

其实坐标是诓你的,你只要求出一颗最大生成树,就是最后保留下来的城墙,其他都可以被拆掉了

 

#include <bits/stdc++.h>
using namespace std;
const int maxn=2e5+10;
int f[maxn];
struct node
{
    int u,v,w;
} a[maxn];

bool cmp(const node &x, const node &y)
{
    return x.w>y.w;
}

int Find(int x)
{
    if(x==f[x]) return x;
    else return f[x]=Find(f[x]);
}

int main()
{
    int n,m,x,y;
    while(~scanf("%d%d",&n,&m))
    {
        int ans=0,num=0,sum=0;
        for(int i=1; i<=n; i++)
        {
            f[i]=i;
            scanf("%d%d",&x,&y);
        }
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a[i].u,&a[i].v,&a[i].w);
            sum+=a[i].w;
        }
        sort(a+1,a+m+1,cmp);
        for(int i=1; i<=m; i++)
        {
            x=a[i].u,y=a[i].v;
            int fx=Find(x),fy=Find(y);
            if(fx!=fy)
            {
                f[fx]=fy;
                num++;
                ans+=a[i].w;
            }
        }
        printf("%d %d\n",m-num,sum-ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值