GCD(hdu 2588)

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3323    Accepted Submission(s): 1782

Problem Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output

For each test case,output the answer on a single line.

Sample Input

3

1 1

10 2

10000 72

Sample Output

1

6

260

Source

ECJTU 2009 Spring Contest

Recommend

lcy

在这里引用陈老师的分析思路:枚举n的因子,只考虑不小于m的,可以在O( sqrt(n) )时间内解决。若n=p*q,x=p*y,gcd(x,n)=p,则gcd(q,y)=1,满足条件y的个数正好是phi[q]。

其实进行分解会发现,就是求欧拉函数。。。

#include<bits/stdc++.h>
using namespace std;
int f[40000];
int g(int n)//欧拉函数
{
    int res=n;
    int m=(int)sqrt(n+0.5);
    for(int i=2;i<=m;i++)
    {
        if(n%i==0)
        {
            res=res/i*(i-1);
            while(n%i==0) n/=i;
        }
    }
    if(n>1) res=res/n*(n-1);
    return res;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i*i<=n;i++)
        {
            if(n%i==0)
            {
                f[cnt++]=i;
                if(i*i<n)
                    f[cnt++]=n/i;
            }
        }
        int ans=0;
        for(int i=0;i<cnt;i++)
        {
            if(f[i]>=m)
                ans+=g(n/f[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值