HDU 2588 GCD [欧拉函数]【数论】

68 篇文章 0 订阅
26 篇文章 0 订阅

题目连接 : 传送阵
————————-.
GCD

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1734 Accepted Submission(s): 852

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample Input
3
1 1
10 2
10000 72

Sample Output
1
6
260

—————————————–.

题目大意 :不用解释了吧 ..

解题思路:
这道题所需要的算法主要为欧拉函数的运用和一点点的GCD知识。
问题所要求的是 gcd( x , n ) > m ,由gcd( x , n )本身可知,gcd求出来的是 x 和n的最大公约数(设为a),即有式子gcd( x ,n )=a , 进一步进行化简可变为gcd( x/a , n/a )=1 , 到了此处这个式子又有了另一层含义——x/a与n/a互素 。在联想到欧拉函数的功能——对正整数n,欧拉函数是小于或等于n的数中与n互质的数的数目。于是将欧拉函数里的n换成n/a,不就正好能求出x/a的个数了吗?x/a的个数不就是我们所要求的x的个数了吗?

转自这里

附本题代码
————————————-.

#include <stdio.h>
#include <vector>
#include <iostream>
#include <stdlib.h>
using namespace std;
#define LL long long int
#define pb push_back

int Euler(int n)
{
    if(n==1)    return 1;
    int m=n;

    for(int i=2; i*i<=m; i++)
        if(m%i==0)
        {
            n-=n/i;
            while(m%i==0)
                m/=i;
        }
    if(m!=1)
    {
        n-=n/m;
    }
    return n;
}

int solve(int n,int m)
{
    int ans=0;
    for(int i=1; i*i<=n; i++)
    {
        if(n%i) continue;
        if(i>=m&&i*i!=n)
            ans += Euler(n/i);
        if(n/i>=m)
            ans += Euler(i);
    }
    return ans;
}

int main()
{
    int _,p=0;
    scanf("%d",&_);
    while(_--)
    {
        int  n,m;
        scanf("%d%d",&n,&m);
        int sum=solve(n,m);
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值