E - Eddy's picture(hdu 1162) (Kruskal)

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12039    Accepted Submission(s): 6049

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 
Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 

Sample Input

3 1.0 1.0 2.0 2.0 2.0 4.0

Sample Output

3.41

题意:在一个平面直角坐标系中,给你n个点,让你算出使得所有点连在一起的最短长度。

无非就是创建边,跑一遍Kruskal算法

#include<bits/stdc++.h>
using namespace std;
const int maxn=0x3f3f3f;
struct point
{
    double x,y;
}t[105];
struct node
{
    int s,e;
    double w;
}a[5000+5];
int father[105];
int n,m;
int Find(int x)
{
    while(x!=father[x]) x=father[x];
    return x;
}
bool cmp(node a,node b)
{
    return a.w<b.w;
}
double Kruskal()
{
    for(int i=0;i<n;i++) father[i]=i;
    sort(a,a+m,cmp);
    double ans=0;
    for(int i=0;i<m;i++)
    {
        int fx=Find(a[i].s);
        int fy=Find(a[i].e);
        if(fx!=fy)
        {
            ans+=a[i].w;
            father[fx]=fy;
        }
    }
    return ans;
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        for(int i=0;i<n;i++) scanf("%lf%lf",&t[i].x,&t[i].y);
        m=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<i;j++)
            {
                a[m].s=i;
                a[m].e=j;
                a[m++].w=sqrt((t[i].x-t[j].x)*(t[i].x-t[j].x)+(t[i].y-t[j].y)*(t[i].y-t[j].y));
            }
        }
        printf("%.2lf\n",Kruskal());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值