Frequent values (POJ 3368)

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains nintegers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

预处理,dp[i]表示a[i]在位置i时出现的次数。对于区间[L,R],存在t>=L,t<=R,[t,R]区间内不存在a[t]==a[t-1],那么[t,R]中的最大值就是区间[t,R]出现次数最大的次数。

#include<bits/stdc++.h>
using namespace std;
const int MAX=1e5+5;
int maxn[MAX][20],dp[MAX],a[MAX],n,q;
void RMQ()
{
    for(int i=1;i<=n;i++) maxn[i][0]=dp[i];
    for(int j=1;(1<<j)<=n;j++)
        for(int i=1;i+(1<<j)-1<=n;i++)
        maxn[i][j]=max(maxn[i][j-1],maxn[i+(1<<(j-1))][j-1]);
}
int query(int L,int R)
{
    if(L>R) return 0;
    int k=log((double)(R-L+1))/log(2.0);
    return max(maxn[L][k],maxn[R-(1<<k)+1][k]);
}
int main()
{
    while(scanf("%d",&n)==1&&n)
    {
        scanf("%d",&q);
        dp[1]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i>1)
            {
                if(a[i]==a[i-1]) dp[i]=dp[i-1]+1;
                else dp[i]=1;
            }
        }
        RMQ();
        while(q--)
        {
            int L,R;
            scanf("%d%d",&L,&R);
            int t=L;
            while(t<=R&&a[t]==a[t-1]) t++;
            printf("%d\n",max(query(t,R),t-L));
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值