I'm Telling the Truth(hdu 3729) (二分最大匹配)

I'm Telling the Truth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2951    Accepted Submission(s): 1458

Problem Description

After this year’s college-entrance exam, the teacher did a survey in his class on students’ score. There are n students in the class. The students didn’t want to tell their teacher their exact score; they only told their teacher their rank in the province (in the form of intervals).
After asking all the students, the teacher found that some students didn’t tell the truth. For example, Student1 said he was between 5004th and 5005th, Student2 said he was between 5005th and 5006th, Student3 said he was between 5004th and 5006th, Student4 said he was between 5004th and 5006th, too. This situation is obviously impossible. So at least one told a lie. Because the teacher thinks most of his students are honest, he wants to know how many students told the truth at most.

Input

There is an integer in the first line, represents the number of cases (at most 100 cases). In the first line of every case, an integer n (n <= 60) represents the number of students. In the next n lines of every case, there are 2 numbers in each line, Xi and Yi (1 <= Xi <= Yi <= 100000), means the i-th student’s rank is between Xi and Yi, inclusive.

Output

Output 2 lines for every case. Output a single number in the first line, which means the number of students who told the truth at most. In the second line, output the students who tell the truth, separated by a space. Please note that there are no spaces at the head or tail of each line. If there are more than one way, output the list with maximum lexicographic. (In the example above, 1 2 3;1 2 4;1 3 4;2 3 4 are all OK, and 2 3 4 with maximum lexicographic)

Sample Input

2 4 5004 5005 5005 5006 5004 5006 5004 5006 7 4 5 2 3 1 2 2 2 4 4 2 3 3 4

Sample Output

3 2 3 4 5 1 3 5 6 7

Source

2010 Asia Tianjin Regional Contest

 二分图的最大匹配问题,左边集是学生序号,右边集是排名区间。要输出字典序最大的解,就需要从序号大到小寻找匹配。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int vis[maxn];
int match[maxn],ma[maxn];
int n;
struct node
{
    int x,y;
}nodes[105];
int Find(int pos)
{
    for(int i=nodes[pos].x;i<=nodes[pos].y;i++)
        if(!vis[i])
        {
            vis[i]=1;
            if(match[i]==-1||Find(match[i]))
            {
                match[i]=pos;
                ma[pos]=i;
                return 1;
            }
        }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(match,-1,sizeof(match));
        memset(ma,-1,sizeof(ma));
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d%d",&nodes[i].x,&nodes[i].y);
        int ans=0;
        for(int i=n;i>=1;i--)
        {
            memset(vis,0,sizeof(vis));
            if(Find(i)) ans++;
        }
        printf("%d\n",ans);
        for(int i=1;i<=n;i++)
            if(ma[i]>0)
            {
                ans--;
                if(ans>0)
                    printf("%d ",i);
                else
                    printf("%d\n",i);
            }
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值