Mount Kattis - secretchamber Secret Chamber at Mount Rushmore

点击打开链接

这个题 我表示不想说点什么了 说实话 有点水 但是 英文  !! 英文  读题读的我心态爆炸 很爆炸 说实话  我最后看样例读懂了题意  然后 大概 题意就是 给几行  字母 第一行的 可以 代替第二行的 可以任意代替 然后 我用的是 深搜 给ac的 然后我朋友想的是 并查集  然后最后样例一直没有过 也不知道为什么 。。

这个是题目

By now you have probably heard that there is a spectacular stone sculpture featuring four famous U.S. presidents at Mount Rushmore. However, very few people know that this monument contains a secret chamber. This sounds like something out of a plot of a Hollywood movie, but the chamber really exists. It can be found behind the head of Abraham Lincoln and was designed to serve as a Hall of Records to store important historical U.S. documents and artifacts. Historians claim that the construction of the hall was halted in 1939 and the uncompleted chamber was left untouched until the late 1990s, but this is not the whole truth.

In 1982, the famous archaeologist S. Dakota Jones secretly visited the monument and found that the chamber actually was completed, but it was kept confidential. This seemed suspicious and after some poking around, she found a hidden vault and some documents inside. Unfortunately, these documents did not make any sense and were all gibberish. She suspected that they had been written in a code, but she could not decipher them despite all her efforts.

Earlier this week when she was in the area to follow the ACM-ICPC World Finals, Dr. Jones finally discovered the key to deciphering the documents, in Connolly Hall of SDSM&T. She found a document that contains a list of translations of letters. Some letters may have more than one translation, and others may have no translation. By repeatedly applying some of these translations to individual letters in the gibberish documents, she might be able to decipher them to yield historical U.S. documents such as the Declaration of Independence and the Constitution. She needs your help.

You are given the possible translations of letters and a list of pairs of original and deciphered words. Your task is to verify whether the words in each pair match. Two words match if they have the same length and if each letter of the first word can be turned into the corresponding letter of the second word by using the available translations zero or more times.

Input

The first line of input contains two integers mm (1m5001≤m≤500) and nn (1n501≤n≤50), where mm is the number of translations of letters and nn is the number of word pairs. Each of the next mm lines contains two distinct space-separated letters aa and bb, indicating that the letter aa can be translated to the letter bb. Each ordered pair of letters (a,b)(a,b) appears at most once. Following this are nn lines, each containing a word pair to check. Translations and words use only lowercase letters ‘a’–‘z’, and each word contains at least 11 and at most 5050 letters.

Output

For each pair of words, display yes if the two words match, and no otherwise.

Sample Input 1Sample Output 1
9 5
c t
i r
k p
o c
r o
t e
t f
u h
w p
we we
can the
work people
it of
out the
yes
no
no
yes
yes
Sample Input 2Sample Output 2
3 3
a c
b a
a b
aaa abc
abc aaa
acm bcm
yes
no
yes

然后我的代码一开始 会 内存超限 因为  递归用的很多  最后不能用的这么夸张  只能 用数组来 标记一下  用过的 字母就不再用了 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#include <math.h>
#include <vector>
#include <map>
#include <set>
using namespace std;
char aa[60];
char bb[60];
bool bj[50];
struct mmp
{
    int xx;
    char zz[55];
}m[32];
bool jd(int x,int y)
{

       bj[x]=1;
       //printf("%d\n",x);
        for(int ii=0;ii<m[x].xx;ii++)
        {     //printf("%c %c\n",m[x].zz[ii],bb[y]);
              if(m[x].zz[ii]==bb[y])
                 return 1;
              if(bj[m[x].zz[ii]-'a'])
                   continue;
              if(jd(m[x].zz[ii]-'a',y))
                  return 1;
        }
        return 0;
}
int main()
{
     int t,tt,lena,lenb,flag,ll;
     char a[3],b[3];
     for(int i=0;i<31;i++)
     {
          m[i].xx=0;
     }
     scanf("%d%d",&t,&tt);
     for(int i=0;i<t;i++)
     {
           scanf("%s",a);
           scanf("%s",b);
           ll=m[a[0]-'a'].xx++;
           m[a[0]-'a'].zz[ll]=b[0];
     }
     for(int i=0;i<tt;i++)
     {      memset(bj,0,sizeof(bj));
            flag=1;
          //printf("%d\n",i);
           scanf("%s%s",aa,bb);
          // printf("%s %s\n",aa,bb);
           lena=strlen(aa);
            lenb=strlen(bb);
           if(lena!=lenb)
           {
               printf("no\n");
               continue;
           }
          for(int j=0;j<lena;j++)
           { 
            memset(bj,0,sizeof(bj));
                if(aa[j]!=bb[j])
                {  // printf("%c %c\n",aa[j],bb[j]);
                    if(!jd(aa[j]-'a',j))
                     {     flag=0;
                           printf("no\n");
                          break;
                     }
                }
          }
           if(flag)
            printf("yes\n");
     }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值