hdu 1213 How Many Tables + 1272 小希的迷宫(基础并查集)

 

 

How Many Tables

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40176    Accepted Submission(s): 20061

 

 

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

 

Sample Input

 

2

5 3

1 2

2 3

4 5

5 1

2 5

 

Sample Output

 

24

【题解】

基础并查集,输出根节点数

【代码】

#include<stdio.h>
#include<string.h>
int pre[1005],c[1005];
int find(int x)
{
    int r=x;
    while(pre[r]!=r)
        r=pre[r];
    int i=x,j;
    while(pre[i]!=r)
    {
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}
void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
        pre[fx]=fy;
}
int main()
{
    int t,n,m,i,a,b;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            pre[i]=i;
        for(i=0;i<m;i++){
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        memset(c,0,sizeof(c));
        int ans=0;
        for(i=1;i<=n;i++)
            c[find(i)]=1;
        for(i=1;i<=n;i++)
            if(c[i])
               ans++;
        printf("%d\n",ans);
    }
    return 0;
}

 

 

小希的迷宫

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60104    Accepted Submission(s): 18880

 

 

Problem Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

 

 

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

 

 

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

 

 

Sample Input

 

6 8 5 3 5 2 6 4

5 6 0 0

8 1 7 3 6 2 8 9 7 5

7 4 7 8 7 6 0 0

3 8 6 8 6 4

5 3 5 6 5 2 0 0

-1 -1

 

Sample Output

 

YesYesNo

 

【题解】

判断图是否连通(根结点唯一)且不成环(每次输入的n,m根结点不同)

【代码】

#include<stdio.h>
#include<string.h>
const int maxn=1e5+5;
int pre[maxn],a[maxn];
int f;
int find(int x)
{
    int r=x;
    while(pre[r]!=r)
        r=pre[r];
    return r;
}
void mix(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
        pre[fx]=fy;
    else
        f=0;
}
int main()
{
    int n,m,i,c;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)
            break;
        if(!n&&!m)
        {
            printf("Yes\n");
            continue;
        }
        memset(a,0,sizeof(a));
        f=1,c=0;
        for(i=1;i<maxn;i++)
            pre[i]=i;
        mix(n,m);
        a[n]=1,a[m]=1;
        while(~scanf("%d%d",&n,&m))
        {
            if(!n&&!m)
               break;
            else
            {
                mix(n,m);
                a[n]=1,a[m]=1;
            }
        }
        for(i=0;i<maxn;i++)
                    if(a[i]&&pre[i]==i)
                        c++;
                if(c>1||!f)
                    printf("No\n");
                else
                    printf("Yes\n");
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值