hdu 3371 Connect the Cities(kruskal算法)

【题目】

 

Connect the Cities

 

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23794 Accepted Submission(s): 5426

 

 

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

 

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

 

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

 

Sample Input

 

16 4 31 4 22 6 12 3 53 4 332 1 22 1 33 4 5 6

Sample Output

 

1

 

Author

dandelion

 

【题解】

kruskal+并查集+路径压缩

不是我的问题,是vjudge有毛病,弄得我改来改去,这不是在hdu就过了么

【代码】

#include<cstdio>
#include<algorithm>
using namespace std;
int pre[505],n,m,k,ans,sum;
struct edge{
     int u,v,c;
}f[25005];
bool cmp(edge a,edge b)
{
    return a.c<b.c;
}
int find(int x)
{
    int r=x;
    while(pre[r]!=r)
        r=pre[r];
    int i=x,j;
    while(pre[i]!=r)
    {
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}
int join(int x,int y)
{
    x=find(x),y=find(y);
    if(x!=y)
    {
        pre[x]=y;
        ans++;
        return 1;
    }
    return 0;
}
void init()
{
    int i,j,t,a,b;
    for(i=1;i<=n;i++)
        pre[i]=i;
    for(i=0;i<m;i++)
        scanf("%d%d%d",&f[i].u,&f[i].v,&f[i].c);
    sort(f,f+m,cmp);
    for(i=0;i<k;i++)
    {
        scanf("%d%d",&t,&a);
        for(j=1;j<t;j++)
        {
            scanf("%d",&b);
            join(a,b);
        }
    }
}
int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        ans=0,sum=0;
        scanf("%d%d%d",&n,&m,&k);
        init();

        for(i=0;i<m;i++)
           if(join(f[i].u,f[i].v))
              sum+=f[i].c;
        if(ans==n-1)
            printf("%d\n",sum);
        else
            printf("-1\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值