1006 Sign In and Sign Out (25 分)

第二个一次AC的甲级题目,繁琐但是不难

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

 

#include<cstdio>
struct Student	{
	char name[20];
	int in_hh;
	int in_mm;
	int in_ss;
	int out_hh;
	int out_mm;
	int out_ss;
} student[100];

bool less(int a,int b)	{
	if(student[a].in_hh != student[b].in_hh )	return student[a].in_hh <= student[b].in_hh;
	else if(student[a].in_mm != student[b].in_mm)	return student[a].in_mm <= student[b].in_mm;
	else if(student[a].in_ss != student[b].in_ss)	return student[a].in_ss <= student[b].in_ss;
}		//如果a的进入时间 小于 b的进入时间,返回true,否则返回false

bool more(int a,int b)	{
	if(student[a].out_hh != student[b].out_hh )	return student[a].out_hh >= student[b].out_hh;
	else if(student[a].out_mm != student[b].out_mm)	return student[a].out_mm >= student[b].out_mm;
	else if(student[a].out_ss != student[b].out_ss)	return student[a].out_ss >= student[b].out_ss;
}

int main()
{
	int n;
	int ini=0,outi=0;
	
	scanf("%d",&n);
	for(int i=0; i<n; i++) {			//读入进入时间和离开时间 
		scanf("%s %d:%d:%d %d:%d:%d",student[i].name,&student[i].in_hh,
		&student[i].in_mm,&student[i].in_ss,&student[i].out_hh,
		&student[i].out_mm,&student[i].out_ss);
	}
	
	for(int i=0; i<n; i++)	{	//对所有人	
		if(less(i,ini))	{		//如果这个进入时间 < 最小进入时间 
			ini = i;
		} 
		if(more(i,outi))	{
			outi = i;
		}
	}
	
	printf("%s %s",student[ini].name,student[outi].name);
	return 0;
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值