1006  Sign In and Sign Out (25分)

Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题意:给出n个人的id、sign in时间、sign out时间,求最早进来的人和最晚出去的人的ID~

思路: 首先想到的是进行排序,对 sign_in 时间进行排序,找出最早进来的人;对 sign_out 时间进行排序,找出最晚出去的人,对应c++代码1 ~~~~      这种思路需要进行两次排序,时间复杂度较大,进行优化,把每次输入的 sign_in 时间、sign_out 时间化为秒,进行比较,找到 sign_in 的最小值,sign_out 的最大值,记录对应的ID,最后输出,此时复杂度较小,对应c++代码2 ~~~~

c++代码1:

#include<iostream>
#include<algorithm>
using namespace std;
typedef struct{
	string ID;
	int h1, m1, s1, h2, m2, s2;
}num;
num a[1010];
int cmp1(num a, num b){
	if(a.h1 == b.h1){
		if(a.m1 == b.m1){
			return a.s1 < b.s1;
		}
		return a.m1 < b.m1;
	}
	return a.h1 < b.h1;
}
int cmp2(num a, num b){
	if(a.h2 == b.h2){
		if(a.m2 == b.m2){
			return a.s2 < b.s2;
		}
		return a.m2 < b.m2;
	}
	return a.h2 < b.h2;
}
int main(){
	int n;		scanf("%d", &n);
	for(int i = 0; i < n; i++){
		cin >> a[i].ID;
		scanf("%d:%d:%d %d:%d:%d", &a[i].h1, &a[i].m1, &a[i].s1,&a[i].h2, &a[i].m2, &a[i].s2);
	}
	sort(a, a+n, cmp1);		cout << a[0].ID << " ";
	sort(a, a+n, cmp2);		cout << a[n-1].ID;
	return 0;
}

c++代码2: 

#include<iostream>
using namespace std;
int main(){
	int n, h1, m1, s1, h2, m2, s2, maxn=0, minn=1e5;
	string ID, sign_in, sign_out;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		cin >> ID;
		scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
		int t1 = h1*3600 + m1*60 + s1;
		int t2 = h2*3600 + m2*60 + s2;
 		if(minn > t1){
 			minn = t1;
 			sign_in = ID;
		 }
		 if(maxn < t2){
		 	maxn = t2;
		 	sign_out = ID;
		 }
	} 
	cout << sign_in << " " << sign_out;
	return 0;
}

Python代码

import time
if __name__ == "__main__":
num = int(input())
record = []
for x in range(num):
line = input().split(" ")
unit = [line[0]]
for i in line[1:]:
timeStruct = time.strptime('2018-01-01 '+i, "%Y-%m-%d %H:%M:%S")
timeStamp = int(time.mktime(timeStruct))
unit.append(timeStamp)
record.append(unit)
early = min([ x[1] for x in record])
late = max([x[2] for x in record])
first = [x for x in range(num) if record[x][1] == early][0]
last = [x for x in range(num) if record[x][2] == late][0]
print(record[first][0], record[last][0])

Java代码

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.text.SimpleDateFormat;
import java.util.Date;
public class Main {
    public static void main(String[] args)throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        int earliest;
        int latest;
        SimpleDateFormat inputFormat = new SimpleDateFormat("HH:mm:ss");
        int num = Integer.valueOf(br.readLine());
        String record[][] = new String[num][3];
        for(int i=0;i<num;i++){
            record[i] = br.readLine().split(" ");
        }
        br.close();
        earliest = 0;
        latest = 0;
        for(int i=1;i<num;i++){
            Date early = inputFormat.parse(record[earliest][1]);
            Date now = inputFormat.parse(record[i][1]);
            if(now.getTime() < early.getTime()){
                earliest = i;
            }
        }
        for(int i=0;i<num;i++){
            Date late = inputFormat.parse(record[latest][2]);
            Date now = inputFormat.parse(record[i][2]);
            if(now.getTime() > late.getTime()){
                latest = i;
            }
        }
        String output;
        output = record[earliest][0]+" "+record[latest][0];
        System.out.print(output);
    }
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值