注意int经过加乘可能超过范围,用long long
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in [0,107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
正确代码
#include<cstdio>
const int Sickle = 29;
const int Galleon = 17*29;
int main()
{
long long g1,s1,k1;
long long g2,s2,k2;
long long a1,a2,sum;
long long g,s,k;
scanf("%lld.%lld.%lld %lld.%lld.%lld",&g1,&s1,&k1,&g2,&s2,&k2);
a1=Galleon*g1 + Sickle*s1 + k1;
a2=Galleon*g2 + Sickle*s2 + k2;
sum=a1+a2;
k = sum%29; sum=(sum - k)/29;
s = sum%17; sum=(sum-s)/17;
g = sum;
printf("%lld.%lld.%lld",g,s,k);
return 0;
}
#include<cstdio>
const int Sickle = 29;
const int Galleon = 17*29;
int main()
{
int g1,s1,k1;
int g2,s2,k2;
int a1,a2,sum;
int g,s,k;
scanf("%d.%d.%d %d.%d.%d",&g1,&s1,&k1,&g2,&s2,&k2);
a1=Galleon*g1 + Sickle*s1 + k1;
a2=Galleon*g2 + Sickle*s2 + k2;
sum=a1+a2;
k = sum%29; sum=(sum - k)/29;
s = sum%17; sum=(sum-s)/17;
g = sum;
printf("%d.%d.%d",g,s,k);
return 0;
}