问题
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
解决方法
分析:进制转化
唯一值得注意的一点是,两个数据相加可能出现int溢出的情况,所以采用long long 存储。
#include<iostream>
using namespace std;
int main()
{
long long galleon, sickle, knut;
long long a, b, c;
scanf("%d.%d.%d", &galleon, &sickle, &knut);
a = galleon * 29 * 17 + sickle * 29 + knut;
scanf("%d.%d.%d", &galleon, &sickle, &knut);
b= galleon * 29 * 17 + sickle * 29 + knut;
c = a + b;
cout << c / (29 * 17) << "." << (c % (29 * 17)) / 29 <<"."<< c % 29;
return 0;
}