网络三层架构搭建——实验

目录

三层架构简介:

实验部分:

使用模拟器:packet tracer拓扑图:​

实验要求及描述:

实验配置:


三层架构简介:

企业级三层架构可以划分为:核心层、汇聚层、接入层
作用与意义:
核心层:进行数据流量的接受与转发
汇聚层:多台接入层设备的汇聚点
接入层:直接面向用户连接或访问网络的部分

实验部分:

使用模拟器:packet tracer
拓扑图:

实验要求及描述:

1.PC0-5为接入层用户,switch0-4为接入层,SW1-2为汇聚层,R1为核心层,R2为ISP,server为内网服务器,PC0,2,3属于vlan2,PC1,4,5属于vlan3
2.内网IP为172.16.0.0/16
3.HSRP/VRRP,STP(PVST+),VLAN,DTP,VTP,Channel均使用
3.使用DHCP下放地址
4.全网可达,且减少路由条目

实验配置:

配置ether channel:
SW1(config)#int range g0/1-2
SW1(config-if-range)#channel-group 1 mode on
SW2同上
修改封装(三层交换机支持dot1q,和ISL;而二层仅支持dot1q):
SW1(config)#int port-channel 1
SW1(config-if)#switchport trunk encapsulation dot1q
SW2同上
手工配置trunk:
SW1(config-if)#switchport mode trunk
如果trunk没有起来,在SW2上也配置上述
在接入层交换机是s1上配置DTP:
s1(config)#int ran f0/3-4
s1(config-if-range)#switchport mode dynamic desirable

但在s4连接server,需要配置地址,并在汇聚层SW1和SW2上要配置IP,所以不能做trunk

配置VTP:
SW1(config)#vtp domain haha
SW1(config)#vtp password 123
SW1(config)#vtp mode server
SW2同上

创建VLAN:
SW1(config)#vlan 2
SW1(config)#vlan 3

在s1上:
s1(config)#vtp domain haha
s1(config)#vtp domain haha
s1(config)#vtp mode client
由于在s2,s3上只有一个VLAN,可以不用做trunk,只用access模式
在s2上:
s2(config)#vtp domain haha
s2(config)#vtp password 123
s2(config)#vtp mode transparent 修改为透明模式
s2(config)#vlan 2
s3同上
s3(config)#vlan 3

接口划入vlan及生成树(PVST+):
在s1上:
s1(config)#int f0/1
s1(config-if)#switchport mode access
s1(config-if)#switchport access vlan 2
s1(config-if)#spanning-tree portfast 端口加速
s1(config-if)#int f0/2
s1(config-if)#switchport mode access
s1(config-if)#switchport access vlan 3
s1(config-if)#spanning-tree portfast
因为s2,s3为透明交换机,不做配置,而是在SW1,SW2上做

SW1(config)#int f0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 2
SW1(config-if)#spanning-tree portfast
SW2同上

s2上配置:
s2(config)#int range f0/1-24
s2(config-if-range)#switchport mode access
s2(config-if-range)#switchport access vlan 2
s2(config-if-range)#spanning-tree portfast
在SW2,SW3及s3配置vlan3同上

配置生成树:
SW1(config)#spanning-tree vlan 2 root primary 主根
SW1(config)#spanning-tree vlan 3 root secondary 备份根
在SW2上进行相反的配置

配置SVI
SW1:
SW1(config)#int vlan 2
SW1(config-if)#ip add 172.16.2.1 255.255.255.128
SW1(config-if)#int vlan 3
SW1(config-if)#ip add 172.16.2.129 255.255.255.128
SW2:
SW2(config)#int vlan 2
SW2(config-if)#ip add 172.16.2.2 255.255.255.128
SW2(config-if)#int vlan 3
SW2(config-if)#ip add 172.16.2.130 255.255.255.128

网管冗余(HSRP):
SW1(config-if)#int vlan 2
SW1(config-if)#standby 1 ip 172.16.2.126
SW1(config-if)#standby 1 priority 101 修改优先级
SW1(config-if)#standby 1 preempt 开启抢占
SW1(config-if)#standby 1 track fastEthernet 0/5 上行链路追踪
SW1(config-if)#int vlan 3
SW1(config-if)#standby 1 ip 172.16.2.254
SW1(config-if)#standby 1 preempt
SW1(config-if)#standby 1 track fastEthernet 0/5
SW2上配置与SW1相反,同上进行配置

配置DHCP:
SW1:
SW1(config)#ip dhcp pool ll
SW1(dhcp-config)#net 172.16.2.0 255.255.255.128 配置网段
SW1(dhcp-config)#default-router 172.16.2.126 配置网关
SW1(dhcp-config)#dns-server 114.114.114.114 配置DNS
SW1(config)#ip dhcp pool kk
SW1(dhcp-config)#default-router 172.16.2.254
SW1(dhcp-config)#network 172.16.2.126
SW1(dhcp-config)#dns-server 114.114.114.114
SW2进行相同的配置,同上

R2为ISP
isp(config)#int f0/0
isp(config-if)#ip add 12.1.1.2 255.255.255.0
isp(config-if)#no sh
isp(config-if)#int lo0
isp(config-if)#ip add 1.1.1.1 255.255.255.0

r1(config)#int f1/0
r1(config-if)#ip add 12.1.1.1 255.255.255.0
r1(config-if)#no sh

配置缺省及NAT:
r1(config)#ip route 0.0.0.0 0.0.0.0 12.1.1.2
r1(config)#ip nat inside source list 1 interface f1/0 overload
r1(config)#int f1/0
r1(config-if)#ip nat outside
r1(config-if)#int f0/0
r1(config-if)#ip nat inside
r1(config-if)#int f0/1
r1(config-if)#ip nat inside
注意开启接口
r1(config-if)#int f0/0
r1(config-if)#ip add 172.16.0.1 255.255.255.252
r1(config-if)#int f0/1
r1(config-if)#ip add 172.16.0.5 255.255.255.252

SW1(config)#ip routing 开启交换机路由功能
SW1(config)#int f0/5
SW1(config-if)#no switchport 关闭接口的交换功能
SW1(config-if)#ip add 172.16.0.2 255.255.255.252
SW2(config)#ip routing
SW2(config)#int f0/5
SW2(config-if)#no switchport
SW2(config-if)#ip add 172.16.0.6 255.255.255.252

配置server:
SW1(config)#int f0/4
SW1(config-if)#no switchport
SW1(config-if)#ip add 172.16.3.1 255.255.255.0
SW1(config)#int f0/4
SW1(config-if)#no switchport
SW1(config-if)#ip add 172.16.3.2 255.255.255.0

SW1(config-if)#standby 1 ip 172.16.3.254
SW1(config-if)#standby 1 preempt
SW1(config-if)#standby 1 priority 101
SW1(config-if)#standby 1 track fastEthernet 0/5

SW2(config-if)#standby 1 ip 172.16.3.254
SW2(config-if)#standby 1 preempt
SW2(config-if)#standby 1 track fastEthernet 0/5

给server配置IP地址:172.16.3.10,掩码:255.255.255.0 ,网关:172.16.3.254

启动EIGRP在R1,SW1,SW2上:
r1(config)#router eigrp 90
r1(config-router)#no auto sumary
r1(config-router)#network 172.16.0.0
r1(config-router)#redistrbute static 进行重发布,将缺省引入
SW1(config)#router eigrp 90
SW1(config-router)#no auto sumary
SW1(config-router)#network 172.16.0.0
SW2(config)#router eigrp 90
SW2(config-router)#no auto sumary
SW2(config-router)#network 172.16.0.0

在SW1,SW2上进行汇总,以减少路由条目:
SW1(config)#int f0/5
SW1(config-if)#ip sumary-address eigrp 90 172.16.2.0 255.255.254.0 进行汇总
SW2(config)#int f0/5
SW2(config-if)#ip sumary-address eigrp 90 172.16.2.0 255.255.254.0

在三层交换机中,如果启用动态路由协议,有几个SVI就会创建几个邻居(如本实验中的EIGRP),这是需要将所有接口改成被动(除与路由器相连的接口):
SW1(config-router)#passive-interface default
SW2(config-router)#passive-interface default
并进行单播邻居的指向:
SW1(config-router)#neighbor 172.16.0.1 f0/5
SW2(config-router)#neighbor 172.16.0.5 f0/5
 

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页