PAT A1096:Consecutive Factors

题目描述

1096 Consecutive Factors (20分)
Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:
Each input file contains one test case, which gives the integer N (1<N<2^31).

Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the formatfactor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
567

求解思路

  1. 从2到sqrt(n)+1开始寻找能够被n整除的数i,如果没有找到则表明n为1或者一个质数。找到的话则先令这个当前的curlen为0,tmp为n,然后从i开始往后遍历找到下一个能够整除tmp的数,找到一个则curlen加一且tmp要除去该数。只有当curlen大于len的时候才会更新len和first的值

代码实现(AC)

#include<cstdio>
#include<cmath>
int n;
void solve()
{
	scanf("%d",&n);
	int maxn=(int)sqrt(1.0*n);
	int first=0,len=0;
	for(int i=2;i<=maxn;i++)
	{
		if(n%i==0)
		{
			int tmp=n;
			int curlen=0;
			for(int j=i;tmp%j==0;j++)
			{
				curlen++;
				if(curlen>len)
				{
					len=curlen;
					first=i;
				}
				tmp/=j;
			}
		}
	}
	if(len==0)
	{
		len=1;
		first=n;
	}
	printf("%d\n",len);
	for(int i=0;i<len;i++)
	{
		if(i<len-1)	printf("%d%c",first+i,'*');
		else printf("%d",first+i);
	}
}
int main()
{
	solve();
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值