PAT-A 1096 Consecutive Factors (20 point(s))

1096 Consecutive Factors (20 point(s))

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

思路:存在连乘序列时,序列中的因数小于等于sqrt(n), 分别将2~sqrt(n)作为连乘序列第一个数,计算其连乘序列长度,并记录最长序列的长度和第一个数.如果在2~sqrt(n)之间不存在n的因数,说明n为1或者为质数.此时连乘序列的最大长度为0,特判输出即可.

#include <cstdio>
#include <cmath>

int main()
{
    int n;
    scanf("%d", &n);
    int sqr = (int)sqrt(1.0 * n);
    int maxlen = 0; //连乘序列的长度
    int first = 0; //连乘序列第一个数

    // 存在连乘序列时,序列中的因数小于等于sqrt(n)
    // 将2~sqrt(n)作为连乘序列第一个数,分别计算其序列长度
    for(int i = 2; i <= sqr; i++)
    {
        int j;
        int temp = 1; // 保存连乘序列的积
        for(j = i; j <= sqr; j++)
        {
            temp *= j;
            if(n % temp != 0) // 如果连乘序列的积不再是n的因数,最后一个j不属于连乘序列
                break;
        }
        if(j - i > maxlen) // 计算连乘序列的长度
        {
            maxlen = j - i;
            first = i;
        }
    }

    // 连乘序列最大长度为0,说明在2~sqrt(n)之间没有出现过n的因数,n为1或素数
    // 第一行输出1, 第二行输出n
    if(maxlen == 0)
        printf("1\n%d", n);
    else
    {
        printf("%d\n", maxlen);
        for(int i = 0; i < maxlen; i++)
        {
            if(i != 0)
                printf("*");
            printf("%d", first + i);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值