HDU 1711 - Number Sequence(KMP)

题目链接:HDU - 1711

                                      Number Sequence

                      Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                     Total Submission(s): 45702    Accepted Submission(s): 18647

 

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

 

Sample Output

6

-1

 

题意解析:

给出两串数字,看看第二串有没有在第一串中出现,如果有,输出它的位置;

完全是个简单的 KMP 的模板题,只要匹配的时候加入需要的条件就好了。

 

代码篇:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int a[8100000], b[90000];
int nt[50000];
int n, m;
void getnext()
{
    int j = 0, k = -1;
    nt[0] = -1;
    while(j < m) ///m代表的是模式串(副串)的长度
    {
        if(k == -1 || b[j] == b[k]) ///匹配成功的话,就匹配下一个字符
        {
            j++;
            k++;
            nt[j] = k;
        }
        else   ///失败了的话,就跳回上一次成功的地方
            k = nt[k];
    }
}
int main()
{
    int x, i, j;
    scanf("%d",&x);
    while(x--)
    {
        scanf("%d %d", &n, &m);
        memset(nt, 0, sizeof(nt));
        for(i = 0; i < n; i++)
            scanf("%d",&a[i]);
        for(i = 0; i < m; i++)
            scanf("%d",&b[i]);
        i = 0, j = 0;
        getnext();
        int flag = 0, sign;
        while(i < n) ///i为在主串中活动的指针,j为在副串中活动的指针
        {
            if(j == m) ///整个串匹配成功
            {
                flag = 1;
                sign = i - j + 1;
                break;
            }
            if(a[i] == b[j] || j == -1) ///单个变量匹配成功,进行下一个变量
            {                           ///j = -1 的时候也就是第一个的时候,直接进行下一个即可
                i++;
                j++;
            }
            else ///单个变量匹配失败,跳回上一次匹配成功的地方
                j = nt[j];
        }
        if(i == n && j == m) ///查看一下最后匹配的时候有没有成功
        {
            flag = 1;
            sign = n - j + 1;
        }
        if(flag)
            printf("%d\n",sign);
        else
            printf("-1\n");
    }
    return 0;
}

 

OVER!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值