HDU-1711-Number Sequence

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
###Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
###Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
###Sample Input
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2
###Sample Output
6
-1

###题目大意:
找到子数列在主数列中第一次出现的头指针。
###解题思路:
KMP模板题,不过是把字符串匹配换成了数字匹配,原理是一样的。
输入用cin的话超时了,换成scanf过的。。。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int p[10010],t[1000010];//子串和主串
int nex[100100];//子串前k项最大前后缀公共长度(下标加1)
void prefix(int len)//预处理,构造nex数组
{
  int k=0;
  for(int i=1;i<len;i++)
  {
    while(k>0&&p[k]!=p[i]) k=nex[k-1];//递归构造
    if(p[k]==p[i])k++;//相同,长度加一
    nex[i]=k;
  }
}
int kmp(int lent,int lenp)//kmp算法核心
{
  int cur=0;
  for(int i=0;i<lent;)
  {
    if(t[i]==p[cur])//匹配成功
    {
      cur++;
      i++;
    }
    else if(cur>0&&t[i]!=p[cur])cur=nex[cur-1];//子串指针尚未恢复到头指针但无法匹配
    else if(cur==0&&t[i]!=p[cur])i++;//恢复到头指针仍然无法匹配
    if(cur==lenp)return i-lenp+1;//返回第一次匹配后的指针
  }
  return -1;//没有匹配到,返回-1
}
int main()
{
  int T;
  scanf("%d",&T);
  while(T--)
  {
    int lenp,lent;
    scanf("%d %d",&lent,&lenp);
    for(int i=0;i<lent;i++)scanf("%d",t+i);
    for(int i=0;i<lenp;i++)scanf("%d",p+i);
    prefix(lenp);
    cout<<kmp(lent,lenp)<<endl;
    memset(nex,0,sizeof(nex));
    memset(p,0,sizeof(p));
    memset(t,0,sizeof(t));
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值