Transport Ship(多重背包+方案数)

                                                   问题 K: Transport Ship

                                                                    时间限制: 1 Sec  内存限制: 128 MB

题目描述

There are N different kinds of transport ships on the port. The i^th kind of ship can carry the weight of V[i] and the number of the ith kind of ship is 2C[i]-1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of S? It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.

 

输入

The first line contains an integer T(1≤T≤20), which is the number of test cases. 
For each test case: 
The first line contains two integers: N(1≤N≤20), Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.
For the next N lines, each line contains two integers: V[i] (1≤V[i]≤20), C[i] (1≤C[i]≤20), representing the weight the i^th kind of ship can carry, and the number of the i^th kind of ship is 2C[i]-1.
For the next Q lines, each line contains a single integer: S (1≤S≤10000), representing the queried weight.

输出

For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 1000000007.

 

样例输入

复制样例数据

1
1 2
2 1
1
2

样例输出

0
1

题目描述:有T组数据,有n条船,q个询问,接下来n行是每条船能装多少重量w和数量c( 2^c-1)下边q行询问的货物重量,问有多少种方案去装货物,每条船必需装满;

#include <bits/stdc++.h>
using namespace std;

int vec[10010];//用STL中的vector时间太长,原因可能是会多次访问vector中的值
int dp[10010],g[10010];
const int inf=0x3f3f3f3f;
const int mod=1e9+7;

int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,mu;
        int p=0;
        scanf("%d%d",&n,&mu);
        for(int i=0; i<n; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            b=(1<<b)-1;

            for(int k=1; k<=b; k=k*2)
            {
                b-=k;
                vec[p++]=a*k;
                //vec.push_back(a*k);
            }
            if(b>0)
               // vec.push_back(a*b);
               vec[p++]=a*b;
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;

        for(int j=0; j<p; j++)
            for(int k=10000; k>=vec[j]; k--)
            {
                if(dp[k-vec[j]]>0)
                    dp[k]+=dp[k-vec[j]];
                if(dp[k]>mod)
                    dp[k]-=mod;
            }


        for(int i=0; i<mu; i++)
        {
            int m;
            scanf("%d",&m);
            printf("%d\n",dp[m]);

        }
    }

    return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值