HDU 4578 Transformation(线段树+有技巧的懒标记下放)

题目链接

Yuanfang is puzzled with the question below: 
There are n integers, a 1, a 2, …, a n. The initial values of them are 0. There are four kinds of operations. 
Operation 1: Add c to each number between a x and a y inclusive. In other words, do transformation a k<---a k+c, k = x,x+1,…,y. 
Operation 2: Multiply c to each number between a x and a y inclusive. In other words, do transformation a k<---a k×c, k = x,x+1,…,y. 
Operation 3: Change the numbers between a x and a y to c, inclusive. In other words, do transformation a k<---c, k = x,x+1,…,y. 
Operation 4: Get the sum of p power among the numbers between a x and a y inclusive. In other words, get the result of a x p+a x+1 p+…+a y p. 
Yuanfang has no idea of how to do it. So he wants to ask you to help him. 

Input

There are no more than 10 test cases. 
For each case, the first line contains two numbers n and m, meaning that there are n integers and m operations. 1 <= n, m <= 100,000. 
Each the following m lines contains an operation. Operation 1 to 3 is in this format: "1 x y c" or "2 x y c" or "3 x y c". Operation 4 is in this format: "4 x y p". (1 <= x <= y <= n, 1 <= c <= 10,000, 1 <= p <= 3) 
The input ends with 0 0. 

Output

For each operation 4, output a single integer in one line representing the result. The answer may be quite large. You just need to calculate the remainder of the answer when divided by 10007.

Sample Input

5 5
3 3 5 7
1 2 4 4
4 1 5 2
2 2 5 8
4 3 5 3
0 0

Sample Output

307
7489

题意:现在给出一个初始值全部为0的一段序列,现在总共有4种操作。

操作一:将[l,r]区间内所有数加上x;

操作二:将[l,r]区间所有数乘以x;

操作三:将[l,r]区间所有数变成x;

操作四:计算[l,r]区间每个数的p次方的和。

题解:要是按照直接记录的放法,这个题的懒标记肯定非常复杂,但是这个题的时间给了8秒,数据也很特别,起始数据都为0。现在我们每次更改过后,那段区间的值也应该是相同的,所以,我们直接可以计算一段区间相同的数的操作的和,

sum=(r-l+1)*a[rt]^p;注意:每次更新和求和时都应该要注意懒标记。

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e5+5;
const int mod=10007;
const int inf=1e9;
const long long onf=1e18;
#define me(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define PI 3.14159265358979323846
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
int n,m;
int sum[maxn<<2],lazy[maxn<<2];
void init(){
    me(sum,0),me(lazy,1);
}
void push_up(int rt){
    if(!lazy[rt<<1]||!lazy[rt<<1|1])///要是子节点的懒标记不为0,说明之前子节点的值已经更改过,现在这个区间值就不一样,不能直接下放
        lazy[rt]=0;
    else if(sum[rt<<1]!=sum[rt<<1|1])///子节点值都不一样,肯定区间值不一样
        lazy[rt]=0;
    else
        lazy[rt]=1,sum[rt]=sum[rt<<1];///可以下放,因为我们每次都是先递归下去更改的子节点的值,所以在更改后将子节点的值赋给父节点。

}
void push_down(int rt){///下放懒标记
    if(lazy[rt]){
        lazy[rt<<1]=lazy[rt<<1|1]=1;
        sum[rt<<1]=sum[rt<<1|1]=sum[rt];
        lazy[rt]=0;
    }
}
void push_date(int L,int R,int opt,int x,int l,int r,int rt){
    if(L<=l&&R>=r&&lazy[rt]){///这里要注意,一定要保证现在区间值都一样才能修改。
        if(opt==1)
            sum[rt]=(sum[rt]+x)%mod;
        else if(opt==2)
            sum[rt]=(sum[rt]*x)%mod;
        else
            sum[rt]=x;
        return ;
    }
    push_down(rt);
    int mid=(l+r)>>1;
    if(L<=mid)
        push_date(L,R,opt,x,lson);
    if(R>mid)
        push_date(L,R,opt,x,rson);
    push_up(rt);
}
int query(int L,int R,int s,int l,int r,int rt){
    if(L<=l&&R>=r&&lazy[rt]){///要保证区间值一样才满足sum=(r-l+1)*a[rt]^p;这个式子。
        int ans=1;
        for(int i=1;i<=s;i++)
            ans=(ans*sum[rt])%mod;
        ans=(ans*(r-l+1))%mod;
        return ans;
    }
    push_down(rt);
    int ans=0;
    int mid=(l+r)>>1;
    if(L<=mid)
        ans+=query(L,R,s,lson);
    if(R>mid)
        ans+=query(L,R,s,rson);
    return ans%mod;
}
int main()
{
    while(scanf("%d%d",&n,&m)&&m+n){
        init();
        while(m--){
            int opt,l,r,x;
            scanf("%d%d%d%d",&opt,&l,&r,&x);
            if(opt==4)
                printf("%d\n",query(l,r,x,1,n,1));
            else{
                push_date(l,r,opt,x,1,n,1);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值