1101 Quick Sort (25 分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题目大意:找主元,主元是前面的都比他小,后面的元素都比他大;

思路1:
正反扫一遍,标记不可能的主元。

完整代码:

#include<bits/stdc++.h>
using namespace std;
const int inf=0x7fffffff;
int main(){
	int n,temp1=0,temp2=inf;
	cin>>n;
	int a[n]={0},b[n]={0},vis[n]={0};
	for(int i=0;i<n;i++) cin>>a[i];
	for(int i=0;i<n;i++){
		if(temp1<a[i]) temp1=a[i];
		else vis[i]=1;
	}
	for(int i=n-1;i>=0;i--){
		if(temp2>a[i]) temp2=a[i];
		else vis[i]=1;
	}
	int cnt=0;
	for(int i=0;i<n;i++)
		if(!vis[i]) b[cnt++]=a[i];
	printf("%d\n",cnt);
        for(int i=0;i<cnt ;i++)
        printf("%d%s",b[i],i==cnt-1? "":" ");
        cout<<endl;
    return 0;
	
} 

思路二:

主元所在位置就是排好序的最终位置,可以排序后和原来数组对比,若相同位置元素不同,那么则不是主元pivot;若相同位置的元素相同,且比前一个元素大,那么他就是主元。

完整代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n,max=0,cnt=0;
    cin>>n;
    int a[n]={0},b[n]={0},v[n]={0};
    for (int i=0;i<n;i++){
        cin>>a[i];
        b[i]=a[i];
    }
    sort(a,a+n);
    for (int i=0;i<n;i++){
        if(a[i]==b[i] && b[i]>max )
        	v[cnt++]=b[i];
        if(b[i]>max) max=b[i];
    }
    cout<<cnt<<"\n";
    for(int i=0;i<cnt;i++)
        printf("%d%s",v[i],i!=cnt-1?" ":"");
    cout<<"\n";
    return 0;
}

End!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值