1103 Integer Factorization (30 分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

题目大意:给除N,K,P,将N分解为K个正整数的P次方。因子降序排,如果有多组,输出底数n1+n2+...nk最大的那组

分析:

一:因子降序排,那就先打表,倒着找因子。

二:对于每一个因子有找或者不找两种情况,那就dfs深搜下。下面说说DFS怎么写:

1)函参确定

index :指向当前因子

tempK:记录当前已经选择的因子个数(题目必须为个因子))

sum:   记录下当前已经选择的因子总和(sum得=N)

facsum:记录底数之和 (题目要求输出底数之和最大那组)

则有:void dfs(int index,int tempK,int sum,int facsum)

开一个vectror<int>temp用于存储临时序列,vector<int>ans用于存储最终序列

2)函数体

递归边界:tempk==K && sum==N 确定一条选择序列,当facsum大于全局最大底数maxfacsum时,刷新maxfacsum并记录序列(ans=temp);tempk>K或者sum>N时应return。

递归体:

就是对fac[index]选或者不选的问题,刷新一下参数即可。注意:为了让下标和底数对应,打表时从0开始,那么fac[0]不应该选,递归前应判断下index>1?或者把这一步放在递归边界判断也可以。

完整代码:
 

#include<bits/stdc++.h>
using namespace std;
int N,K,P;
vector<int>fac,temp,ans;

void init(){
	int i=0,temp=0;// i=0开始是为了让下标和底数相对应比如fac[0]=0,fac[1]=1,fac[2]=4; 
	while(temp<=N){
		temp=pow(i++,P);
		fac.push_back(temp);
    }
}

int maxfacsum=-1;
void dfs(int index,int tempK,int sum,int facsum){
	if(tempK==K && sum==N){ //递归边界1 
		if(facsum>maxfacsum){
			ans=temp;
			maxfacsum=facsum;
		}
		return ;
	}
	if(tempK>K || sum >N) return ; //及时退出,不然会有段错误??? 
	if(index>=1 ){  //fac[0]不选 
	    temp.push_back(index); 
	    dfs(index,tempK+1,sum+fac[index],facsum+index);
	    temp.pop_back();//回溯 
	    dfs(index-1,tempK,sum,facsum);
	}
}
	
int main(){
	cin>>N>>K>>P;
	init();
	dfs(fac.size()-1,0,0,0);
	if(maxfacsum==-1) cout<<"Impossible\n";
	else{
		printf("%d = ",N);
		for(int i=0;i<ans.size();i++){
			printf("%d^%d%s",ans[i],P,i!=ans.size()-1? " + ":"");		
		}
	}
	return 0; 
}

End!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值