1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the Nlines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

这个模拟题需要用到队列,即开始的时候创建N个队列,给定时间无限长,我设定的10000分钟,保证每个人都能办理完。按照要求将人员一一入队,每过一分钟,将队首元素的time,即办理业务所需时间减1,如果time值变为0,说明业务已经办理完成,记录该人员结束的时间leaveTime。再下一分钟时检验还有哪些队列大小小于M,小于的队列在人员还有剩余的情况下入队,如此循环即可。因为设定的时间足够长,所以每个人都能办理完业务,因此我们在最后输出时间的时候需要判断每个人员办理开始的时间leaveTime-constTime是否超过下午5点,即540,若超过则表示未能办理。程序如下:

#include <iostream>
#include <queue>
using namespace std;
struct Peo{
    int time, constTime, leaveTime, ind;
}p[1001];
queue<Peo> q[21];
int main(int argc, char const *argv[])
{
    int N, M, K, Q;
    cin >> N >> M >> K >> Q;
    for (int i = 1; i <= K; ++i){
        cin >> p[i].time;
        p[i].ind = i;
        p[i].constTime = p[i].time;
    }
    int index = 1, cnt = 1;
    for (int i = 1; i <= 10000; ++i){
        while(cnt <= N*M && index<=K){
            for (int j = 1; j <= N; ++j){
                if(q[j].size()<M) {
                    q[j].push(p[index++]);
                    cnt++;
                }
            }
        }
        for (int j = 1; j <= N; ++j){
            int ind = q[j].front().ind;
            p[ind].time--;
            if(p[ind].time==0){
                p[ind].leaveTime = i;
                q[j].pop();
                cnt--;
            }
        }
    }
    for (int i = 0; i < Q; ++i){
        int num;
        cin >> num;
        if(p[num].leaveTime-p[num].constTime<540) 
            printf("%02d:%02d\n", (p[num].leaveTime+480)/60, (p[num].leaveTime+480)%60);
        else printf("Sorry\n");
    }
    return 0;
}


原文链接:https://blog.csdn.net/qq_40438165/article/details/100048982

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值