1014 Waiting in Line (30 分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
- The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
- Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
- Customeri will take Ti minutes to have his/her transaction processed.
- The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.
At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM
where HH
is in [08, 17] and MM
is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.
Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry
Code
#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
#include <iomanip>
#define INF 0x3f3f3f3f
using namespace std;
struct Client
{
int total_serve_time; // 顾客所需服务时间
int res_serve_time; // 顾客剩余所需服务时间
int finish_time; // 顾客服务完成时间
Client() : total_serve_time(-1), res_serve_time(-1), finish_time(0){}
Client(int t_time) : total_serve_time(t_time), res_serve_time(t_time), finish_time(0) {}
};
queue<int> window[20]; // 模拟银行窗口
vector<Client> cli_vec; // 保存客户信息
int M, N, K, Q;
int find_window() // 找到客户剩余所需服务时间最小的窗口号
{
int index = -1, time = INF;
for (int i = 0; i < N; i++)
{
if (!window[i].empty())
{
int temp = window[i].front();
if (cli_vec[temp].res_serve_time < time)
{
time = cli_vec[temp].res_serve_time;
index = i;
}
}
}
return index;
}
int main()
{
// M maxNum of per line
// N number of window
// K num of customers
// Q num of query list
cin >> N >> M >> K >> Q;
int yellow_line = N * M; // 黄线中最大容量
for (int i = 0; i < K; i++)
{
int serve_time;
cin >> serve_time;
cli_vec.push_back(Client(serve_time));
}
for (int i = 0; i < min(yellow_line, K); i++) // 注意K不一定大于yellow_line
{ // 不然会出现段错误
window[i%N].push(i);
}
int curr_time = 0; // 当前时间
int curr_client = min(yellow_line,K); // 现在队列中客户数
int next_client = curr_client; // 下一个要加入队列的客户号
while (curr_client > 0)
{
int wi = find_window();
int ci = window[wi].front();
Client c = cli_vec[ci];
vector<int> less_window; // 保存这次有客户完成业务的窗口号
for (int i = 0; i < N; i++)
{
if (!window[i].empty())
{
int temp = window[i].front();
cli_vec[temp].res_serve_time -= c.res_serve_time;
cli_vec[temp].finish_time = curr_time + c.res_serve_time;
if (cli_vec[temp].res_serve_time == 0) // 如果客户完成业务
{
window[i].pop();
curr_client--;
less_window.push_back(i);
}
}
}
curr_time += c.res_serve_time; // 更新当前时间
sort(less_window.begin(), less_window.end(),
[](const int wi1, const int wi2)->bool {
if (window[wi1].size() != window[wi2].size())
return window[wi1].size() < window[wi2].size();
else
return wi1 < wi2;
}); // 把窗口人数少的,窗口号小的排在前面,优先接纳客户
for (int i = 0; i < less_window.size(); i++)
{
int wi = less_window[i];
if (next_client < K)
{
window[wi].push(next_client);
next_client++;
curr_client++;
}
}
}
for (int i = 0; i < Q; i++)
{
int qi; cin >> qi;
int serve_time = cli_vec[qi - 1].total_serve_time;
int finish_time = cli_vec[qi - 1].finish_time;
int h, m;
h = 8 + finish_time / 60;
m = finish_time % 60;
if (finish_time - serve_time >= 540) cout << "Sorry" << endl; // 注意在17点前开始业务的客户不输出Sorry,
//只有在17点之后开始业务的输出Sorrry
else cout << setw(2) << setfill('0') << h << ':' << setw(2) << setfill('0') << m << endl;
}
return 0;
}
思路
总体思路是这样的,按照时间来,每次都找出当前正在办理业务的客户中,所剩需要服务时间最短的,更新所有窗口客户所剩需要服务的时间的信息,将剩余所需服务时间为0的客户移出队列,再将后续客户按照队列最短,队列号最小的顺序,加入队列。
以上