1014 Waiting in Line (30分)

问题

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.
Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

解决方法

题目大意

有n个客户,k个窗⼝。已知每个客户的到达时间和需要的时⻓,如果有窗⼝就依次过去,
如果没有窗⼝就在⻩线外等候(⻩线外只有⼀个队伍,先来先服务),求客户的平均等待时⻓。银⾏
开放时间为8点到17点,再8点之前不开⻔,8点之前来的⼈都要等待,在17点后来的⼈不被服务。

思路

在这里插入图片描述

代码

#include<iostream>
#include<queue>
using namespace std;
struct node
{
	int endtime, poptime;
	queue<int>q;
}window[22];
int ans[1111], needtime[1111];
int main()
{
	int n, m, k, q, query, index = 0;
	scanf("%d %d %d %d", &n, &m, &k, &q);
	for (int i = 0; i < k; i++) scanf("%d", &needtime[i]);
	for (int i = 0; i < n; i++) window[i].endtime = window[i].poptime = 480;
	for (int i = 0; i < min(n*m, k); i++)
	{
		window[index%n].q.push(index);
		window[index%n].endtime += needtime[index];
		if (index < n) window[index].poptime = needtime[index];
		ans[index] = window[index%n].endtime;
		index++;
	}
	for (; index < k; index++)
	{
		int idx = -1, minpoptime = 99999999999999;
		for (int i = 0; i < n; i++)
		{
			if (window[i].poptime < minpoptime)
			{
				idx = i;
				minpoptime = window[i].poptime;
			}
		}
		window[idx].q.pop();
		window[idx].q.push(index);
		window[idx].endtime += needtime[index];
		window[idx].poptime += needtime[window[idx].q.front()];
		ans[index] = window[idx].endtime;
	}
	for (int i = 0; i < q; i++)
	{
		scanf("%d", &query);
		if (ans[query - 1] - needtime[query - 1] >= 17*60) printf("Sorry\n");
		else printf("%02d:%02d\n", ans[query - 1] / 60, ans[query - 1] % 60);
	}
	return 0;
}

后记

这道题是模拟类型的好题目,是1017的高阶版本。
♦其中有一个特别注意的地方,也是一个坑。后面的人在前面的办完之后,入队是根据队列的长短,不是队列的最后一个人的时间最早,毕竟不能未卜先知,这也是符合生活实际情况的。。。
♦另外一个就是这道题是以0点为基准,不是八点。不知道脑子里想的啥,昨天写的以八点为基准,导致最后两个测试点过不去。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值