1134 Vertex Cover (25 point(s))

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

//其中Nv是集合中顶点的数量,v [i]是顶点的索引。

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

题目大意::给你一张图,对于图中的每条边,如果该边(一条边有两个点)至少有一个点在集合里,如果这个图中的每个边都是满足的,那么我们把这个集合叫做vertex cover,现在给你几个集合,让你判断他们每个是不是这样的集合

这道题思路很简单:就是把图的信息录入,对于每一个集合S,在遍历集合中每一个结点的索引(注意,集合S中存的是索引,不是结点)过程中,把索引到的结点标记一下。如果遍历完集合S,还存在没有标记的结点,输出No,否则输出Yes。

// 好烦啊,题意理解半天,真的很劝退。

PS:PTA中文件读入模板:

#include<bits/stdc++.h> 
using namespace std;   
int main(){    
    #ifdef ONLINE_JUDGE    
    #else    
    freopen("1.txt", "r", stdin);    
    #endif    
    /*your code*/
    return 0;
}

在源文件的同级目录下建立一个1.txt文件即可,然后把输入数据复制到1.txt中即可。

AC code:

#include<bits/stdc++.h> 
using namespace std;   
int main(){    
    #ifdef ONLINE_JUDGE    
    #else    
    freopen("1.txt", "r", stdin);    
    #endif    
    int n,m,k,nv,num;
    cin>>n>>m;
    vector<int> v[n];
    for (int i=0;i<m;i++){
    	int a,b;
        cin>>a>>b;
        v[a].push_back(i); //a结点属于边i
        v[b].push_back(i); //b结点属于边i
    }
    cin>>k;
    for (int i<k;i++){
        cin>>nv;
        int flag=0;
        vector<int>hash(m, 0);
        for (int j=0;j<nv;j++){
            cin>>num;
            for (int t=0;t<v[num].size(); t++)
                hash[v[num][t]] = 1;
        }
        for (int j = 0; j < m; j++) {
            if (hash[j] == 0) {
                printf("No\n");
                flag = 1;
                break;
            }
        }
        if (flag == 0) printf("Yes\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值