1134 Vertex Cover (25 point(s))
A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:
Nv v[1] v[2]⋯v[Nv]
where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.
Output Specification:
For each query, print in a line Yes
if the set is a vertex cover, or No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
图的存储、STL。
题意:Vertex Cover是指这样一个结点集合,每一条边都存在该集合的结点。
思路:用pair<int,int>存储这些边,用哈希表标记结点,然后遍历边即可。
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
const int MAX = 1e4+7;
vector<pair<int,int> >v;
bool mark[MAX]={false};
int main(void){
int N,M,K,a,b;cin>>N>>M;
while(M--){
cin>>a>>b;
v.push_back(pair<int,int>(a,b));
}
cin>>K;int size,x;
while(K--){
cin>>size;
memset(mark,false,sizeof(mark));
for(int i=0;i<size;i++){
cin>>x;
mark[x]=true;
}
bool flag = true;
for(auto i:v){
if(!mark[i.first]&&!mark[i.second]) {
flag = false;
break;
}
}
if(flag) puts("Yes");
else puts("No");
}
return 0;
}