1123 Is It a Complete AVL Tree (30 point(s))

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpgF2.jpg
F3.jpgF4.jpg

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.

Sample Input 1:

5
88 70 61 63 65

Sample Output 1:

70 63 88 61 65
YES

Sample Input 2:

8
88 70 61 96 120 90 65 68

Sample Output 2:

88 65 96 61 70 90 120 68
NO

题目大意:给你n个数据,让你创建一个AVL,然后输出它的层次遍历并判断它是不是一颗完全二叉树。

分析:
1)如何创建AVL:参考模板

2)完全二叉树的判断&&层次遍历输出:完全二叉树判断模板

完全二叉树的判断借助层次遍历完成:

做法:层次遍历时将所有结点入队(包括非空结点),开一个cnt,记录层次遍历已经输出的结点总数。遍历过程中如果空结点后面还有非空结点,那就不是完全二叉树  -->转化为 遇到空指针时 cnt<n ,此时 flag标记一下 ( n为总结点数)。最后BFS()返回flag即可。

完整代码:

#include<bits/stdc++.h>
using namespace std;
int n;
struct node{
	int val;
	node *l,*r;
};
node *RR(node *root){ // 右旋 
	node *temp=root->l;
	root->l =temp->r ;
	temp->r=root;
	return temp;
}

node *LL(node *root){ //左旋 
	node *temp=root->r ;
	root->r =temp->l ;
	temp->l =root;
	return temp;
}

node *RL(node *root){//麻烦结点在右子树的左子树 
	root->r=RR(root->r );
	return LL(root);
}

node *LR(node *root){ //麻烦结点在左子树的右子树 
	root->l=LL(root->l );
	return RR(root);
}

int getHeight(node *root){
	if(!root) return 0;
	return max(getHeight(root->l),getHeight(root->r ) ) +1;
}
 
node *insert(node *&root, int val) {  //建立 BST tree 并调整平衡,不能有相同节点 
    if(!root) {
        root = new node;
        root->val = val;
        root->l= root->r = NULL;
    } else if(val < root->val) {
        insert(root->l, val); //插入
        if(getHeight(root->l) - getHeight(root->r) ==2)
            root = val < root->l->val ? RR(root) : LR(root);   //旋转调整平衡 
    } else {
        insert(root->r, val);//插入
        if(getHeight(root->l) - getHeight(root->r) == -2)
            root = val > root->r->val ? LL(root) : RL(root); //旋转调整平衡
    }
    return root;
}

bool BFS(node *root){
	if(!root) return true;
	queue<node*>q;
	q.push(root);
	bool flag=true;
	int cnt=0;
	while(!q.empty()){
		node *temp=q.front();
		q.pop();
		if(temp!=NULL){
			cnt++;
			printf("%d%s",temp->val,cnt==n?"\n":" ");
			q.push(temp->l ); //不用判空,直接入队
			q.push(temp->r );
		}else 
			if(cnt<n) flag=false;//说明空结点后还有非空结点 
    }
	return flag;
}
			
int main(){
	cin>>n;
	node *root=NULL;
	for(int i=0;i<n;i++){
		int val;
		cin>>val;
		root=insert(root,val);
	}
	printf("%s",BFS(root)>0? "YES\n":"NO\n");
	return 0;
}			

That‘s all !

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值