PAT 甲级 1029 Median (25 分) 我的思路(我认为很简单的思路)

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

 我的思路:

这题想考排序,C++的sort真是好用。

我的思路是:用一个大小为400000的long数组存输入的数字(这里先记为len吧),sort一下,判断输入数字的个数是奇数还是偶数,若为奇数,输出在数组里位置为len/2的元素;为偶数,输出在数组里位置为len/2-1的元素(因为要输出前一半最后一个元素).

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define r 200004
long a[2*r];
int main()
{
	int n,m,i,j;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	scanf("%ld",&a[i]);
	scanf("%d",&m);
	for(i=0;i<m;i++)
	scanf("%ld",&a[i+n]);
	sort(a,a+m+n);
	if((m+n)%2==0)
	{
		printf("%ld\n",a[(m+n)/2-1]);
	}
	else
	{
		printf("%ld\n",a[(m+n)/2]);
	}
	return 0;
}

做完这题,我习惯性的找其他人的答案,看有没有新奇而简洁的思路,但是,我看了一圈,没有几个比我这个代码简洁。

that's all , thank you !

 

 

 

 

 

 

 

 

 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值